it-swarm.com.de

Kompozer kann in Ubuntu 16.04 nicht installiert werden

Beim Versuch, Kompozer in Ubuntu 16.04 zu installieren, wurde die folgende Fehlermeldung angezeigt.

[email protected]:~$ Sudo apt-get install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libidl0 libnspr4 libnss3 libpango1.0-0 libpng12-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g  
Reading package lists... Done  
Building dependency tree...
Reading state information... Done  
Package libidl0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libidl-2-0:i386 libidl-2-0

E: Package 'libidl0' has no installation candidate

Bitte helfen Sie mir, dieses Problem zu lösen.

4
Sshah

Installieren Sie dieselben Pakete, die Sie zuvor installiert haben, mit Ausnahme von libidl0. Öffnen Sie das Terminal und geben Sie Folgendes ein:

Ubuntu 14.04-16.04

Sudo apt install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libnspr4 libnss3 libpango1.0-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g   
  • 32-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_i386.deb
    Sudo apt install ./libidl0_0.8.14-1_i386.deb
    Sudo apt install ./kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    Sudo apt install ./kompozer_0.8~b3.dfsg.1-0.1ubuntu2_i386.deb 
    
  • 64-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_AMD64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_AMD64.deb
    Sudo apt install ./libidl0_0.8.14-1_AMD64.deb
    Sudo apt install ./kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    Sudo apt install ./kompozer_0.8~b3.dfsg.1-0.1ubuntu2_AMD64.deb 
    

Ubuntu 16.10-19.10

Sudo apt install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libnspr4 libnss3 libpango1.0-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g 
  • 32-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_i386.deb  
    Sudo apt install ./libidl0_0.8.14-1_i386.deb  
    Sudo apt install ./libpng12-0_1.2.54-1ubuntu1_i386.deb
    Sudo apt install ./kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    Sudo apt install ./kompozer_0.8~b3.dfsg.1-0.1ubuntu2_i386.deb 
    
  • 64-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_AMD64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_AMD64.deb  
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_AMD64.deb  
    Sudo apt install ./libidl0_0.8.14-1_AMD64.deb  
    Sudo apt install ./libpng12-0_1.2.54-1ubuntu1_AMD64.deb
    Sudo apt install ./kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    Sudo apt install ./kompozer_0.8~b3.dfsg.1-0.1ubuntu2_AMD64.deb 
    
7
karel

Die obige Antwort für Ubuntu 16.04 64-Bit funktioniert nicht mehr. Problem bei Sudo dpkg -i libidl0_0.8.14-1_AMD64.deb:

[email protected]:~/Software/Kompozer$ Sudo dpkg -i libidl0_0.8.14-1_AMD64.deb
[Sudo] password for john: 
Selecting previously unselected package libidl0:AMD64.
(Reading database ... 366612 files and directories currently installed.)
Preparing to unpack libidl0_0.8.14-1_AMD64.deb ...
Unpacking libidl0:AMD64 (0.8.14-1) ...
Replaced by files in installed package libidl-2-0:AMD64 (0.8.14-4) ...
dpkg: dependency problems prevent configuration of libidl0:AMD64:
 libidl-2-0:AMD64 (0.8.14-4) breaks libidl0 (<< 0.8.14-3) and is installed.
  Version of libidl0:AMD64 to be configured is 0.8.14-1.

dpkg: error processing package libidl0:AMD64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libidl0:AMD64

Gelöst von:

Sudo apt-get -f install
Sudo apt-get remove libidl-2-0
Sudo dpkg -i libidl0_0.8.14-1_AMD64.deb

und dann wie vorher.

2
John Rose

Das Problem, auf das in meinem Kommentar zum Ausfall des 16.04 Bezug genommen wurde, wurde im 18.04 behoben. Bei einer Neuinstallation von 18.04 erhalte ich jedoch jetzt: john @ JohnPC: ~/Software/Kompozer $ Sudo dpkg -i kompozer_0.8 ~ b3.dfsg.1-0.1ubuntu2_AMD64.deb Auswahl eines zuvor nicht ausgewählten Pakets kompozer. (Datenbank wird gelesen ... 264748 Dateien und Verzeichnisse sind derzeit installiert.) Vorbereiten des Entpackens von kompozer_0.8 ~ b3.dfsg.1-0.1ubuntu2_AMD64.deb ... Entpacken von kompozer (1: 0.8 ~ b3.dfsg.1-0.1ubuntu2) ... dpkg: Abhängigkeitsprobleme verhindern die Konfiguration von kompozer: kompozer ist abhängig von libpango1.0-0 (> = 1.14.0); jedoch: Paket libpango1.0-0 ist nicht installiert.

dpkg: Fehler beim Verarbeiten des Pakets kompozer (--install): Abhängigkeitsprobleme - unkonfigurierte Verarbeitungsauslöser für man-db (2.8.3-2) ... Verarbeitungsauslöser für Gnome-Menüs (3.13.3-11ubuntu1.1) .. Verarbeitungs-Trigger für Desktop-File-Utils (0.23-1ubuntu3.18.04.1) ... Verarbeitungs-Trigger für MIME-Support (3.60ubuntu1) ... Bei der Verarbeitung von: kompozer sind Fehler aufgetreten

Dieser Fehler wird durch Sudo apt install libpango1.0-0 behoben, gefolgt von Sudo dpkg -i kompozer_0.8 ~ b3.dfsg.1-0.1ubuntu2_AMD64.deb

0
John Rose