it-swarm.com.de

Kernel installiert, aber nicht aktiv 16.04.4 LTS

Der Software-Updater hat den neuesten Kernel 4.4.0-130 installiert. Ich habe ihn dann neu gestartet, konnte ihn aber nicht im Menü der erweiterten Einstellungen von Grub finden. Ich habe danach gesucht und festgestellt, dass es nicht lief:

dpkg -l | grep linux-image
rc  linux-image-4.4.0-109-generic               4.4.0-109.132                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc  linux-image-4.4.0-112-generic               4.4.0-112.135                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc  linux-image-4.4.0-116-generic               4.4.0-116.140                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc  linux-image-4.4.0-119-generic               4.4.0-119.143                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc  linux-image-4.4.0-121-generic               4.4.0-121.145                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
rc  linux-image-4.4.0-122-generic               4.4.0-122.146                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-124-generic               4.4.0-124.148                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-127-generic               4.4.0-127.153                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-128-generic               4.4.0-128.154                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-130-generic               4.4.0-130.156                                AMD64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP

uname -r 
4.4.0-128-generic

Ich ließ dann Grub Customizer laufen, wo der neue Kernel aufgelistet wurde, speicherte die neue Konfiguration und startete erneut. Der neue Kernel läuft immer noch nicht. Ich habe dann das Terminal geöffnet und lief:

Sudo update-grub

Ich habe erneut mit dem gleichen Ergebnis neu gestartet.

Update: -128 und -130 scheinen zu booten, hängen sich aber kurz vor der Desktop-Oberfläche auf, als ob Kaskadenfehler auftreten würden, bei denen der vorherige Kernel jetzt Bootprobleme hat. Derzeit läuft 4.4.0-124

Wie soll ich vorgehen, um Fehler zu beheben und den neuen Kernel so laufen zu lassen, wie es normalerweise nach einer solchen Aktualisierung der Fall wäre? Kann ich -130 löschen und das Update über apt erneut installieren? Was ist ein sicherer Weg, das zu tun?

Auf Anfrage bearbeiten:

:~$ df
Filesystem     1K-blocks      Used Available Use% Mounted on
udev             1900716         0   1900716   0% /dev
tmpfs             384252      6096    378156   2% /run
/dev/sda6       40197496   8797872  29334628  24% /
tmpfs            1921244     45500   1875744   3% /dev/shm
tmpfs               5120         4      5116   1% /run/lock
tmpfs            1921244         0   1921244   0% /sys/fs/cgroup
/dev/loop0         38528     38528         0 100% /snap/handbrake-jz/132
/dev/loop2         38528     38528         0 100% /snap/handbrake-jz/133
/dev/loop1        142848    142848         0 100% /snap/gnome-3-26-1604/64
/dev/loop3         38656     38656         0 100% /snap/handbrake-jz/134
/dev/loop6         89088     89088         0 100% /snap/core/4917
/dev/loop4         88704     88704         0 100% /snap/core/4650
/dev/loop5         89088     89088         0 100% /snap/core/4830
/dev/sda7      502672688 410111864  71567120  86% /home
tmpfs             384252        88    384164   1% /run/user/1000
:~$ df -i
Filesystem       Inodes  IUsed    IFree IUse% Mounted on
udev             475179    521   474658    1% /dev
tmpfs            480311    756   479555    1% /run
/dev/sda6       2564096 339157  2224939   14% /
tmpfs            480311    147   480164    1% /dev/shm
tmpfs            480311      3   480308    1% /run/lock
tmpfs            480311     16   480295    1% /sys/fs/cgroup
/dev/loop0          511    511        0  100% /snap/handbrake-jz/132
/dev/loop2          502    502        0  100% /snap/handbrake-jz/133
/dev/loop1        27651  27651        0  100% /snap/gnome-3-26-1604/64
/dev/loop3          503    503        0  100% /snap/handbrake-jz/134
/dev/loop6        12842  12842        0  100% /snap/core/4917
/dev/loop4        12841  12841        0  100% /snap/core/4650
/dev/loop5        12841  12841        0  100% /snap/core/4830
/dev/sda7      31932416 117242 31815174    1% /home
tmpfs            480311     37   480274    1% /run/user/1000
:~$ 

Ausgabe neu installieren:

:~$ Sudo apt install --reinstall linux-image-generic
[Sudo] password for x: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-124 linux-headers-4.4.0-124-generic
  linux-headers-4.4.0-127 linux-headers-4.4.0-127-generic
  linux-image-4.4.0-124-generic linux-image-4.4.0-127-generic
  linux-image-extra-4.4.0-124-generic linux-image-extra-4.4.0-127-generic
Use 'Sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 10 not upgraded.
Need to get 0 B/2,532 B of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 316411 files and directories currently installed.)
Preparing to unpack .../linux-image-generic_4.4.0.130.136_AMD64.deb ...
Unpacking linux-image-generic (4.4.0.130.136) over (4.4.0.130.136) ...
Setting up linux-image-generic (4.4.0.130.136) ...
:~$

Nach dem Neustart:

:~$ uname -r
4.4.0-130-generic
:~$

Ich habe 10-mal mit dem gleichen SOLVED RESULT neu gestartet und auch frühere Kernel auf -124 zurückgetestet. Dabei wurde festgestellt, dass kurz vor der Desktop-Oberfläche kein (harter) Start mehr auftritt. Anscheinend hat dies meine Probleme gelöst user535733, wenn Sie Ihre Gedanken als gepostete Antwort wiederholen, würde ich Ihnen gerne den Kredit geben. Ich werde dies zur späteren Bezugnahme und Erbauung genauer untersuchen.

1
xtrchessreal

Das erste eindeutige Problem ist, dass Sie nicht den neuesten Kernel installiert haben: Ihr letzter Kernel ist -130, während Ubuntu derzeit -136 verteilt. Der häufigste Grund für diese Art von Problem ist, dass Ihr Metapaket linux-image-generic nicht mehr aktuell ist.

Lösung: Verwenden Sie Sudo apt install --reinstall linux-image-generic, um das Metapaket zu aktualisieren. Dadurch wird wiederum der neueste Kernel für Ihre Ubuntu-Version geladen.

Sie scheinen ein anderes vageres zweites Problem mit mehreren Symptomen gehabt zu haben:

  • Veraltetes linux-image-generic Metapaket
  • Kernel werden installiert, aber in GRUB nicht angezeigt

Es gibt mehrere mögliche Ursachen für diese Symptome zusammen:

  • Nicht genügend Speicherplatz in / oder /boot: Überprüfen Sie mit df
  • Out of Disk Inodes: Überprüfen Sie mit df -i
  • Apt-Konflikt: Schauen Sie sich die apt-Fehlermeldungen an

Speicherplatz- und Apt-Probleme klären sich normalerweise nicht von selbst. Es ist wahrscheinlich, dass Sie etwas getan haben - ob Sie es wissen oder nicht -, um das Problem zu lösen.

1
user535733