it-swarm.com.de

Kann Git nicht auf Ubuntu 16.04 LTS installieren

Beim Versuch, Git unter Ubuntu 16.04 zu installieren, erhalte ich eine Fehlermeldung. Der Befehl, mit dem ich git installiert habe, lautet:

Sudo apt-get install git

Der Fehler, auf den ich gestoßen bin, war:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  git : Depends: liberror-Perl but it is not going to be installed
        Depends: git-man (> 1:2.7.4) but it is not going to be installed
        Depends: git-man (< 1:2.7.4-.) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

Obwohl ich den vorgeschlagenen Befehl (apt-get -f install) verwendet habe, um git zu installieren, bleibt der Fehler bestehen. Wer hat die Idee, dieses Problem zu beheben?

5
Chamber

Manchmal sind unsere Systeme möglicherweise nicht auf dem neuesten Stand, um eine Installation zu erhalten, sodass wir aktualisieren können mit:

  • paketinformationen aktualisieren:

    Sudo apt-get update
    
  • upgradepakete auf dem System nd Korrigieren Sie dabei defekte Pakete:

    Sudo apt-get -f dist-upgrade
    
  • nur kaputte Pakete reparieren:

    Sudo apt-get -f install
    
6
George Udosen

Ich hatte das gleiche Problem mit liberror-Perl beim Versuch, git zu installieren. Die anderen Antworten (Sudo apt-get update && Sudo apt-get dist-upgrade && apt-get -f install) haben bei mir nicht funktioniert.

Wenn Sie die Kette der Abhängigkeitsprobleme manuell verfolgen, indem Sie versuchen, jedes Paket direkt zu installieren, liegt das Problem anscheinend bei Perl-base:

$ Sudo apt install liberror-Perl
  liberror-Perl : Depends: Perl but it is not going to be installed

$ Sudo apt install Perl
  Perl : Depends: Perl-base (= 5.22.1-9) but 5.22.1-9ubuntu0.5 is to be installed

$ Sudo apt install Perl-base
  Perl-base is already the newest version (5.22.1-9ubuntu0.5).

Das Paket Perl hängt also von einer veralteten Version von Perl-base ab. Ich bin nicht sicher, wie das verursacht wurde, aber ich vermute, dass irgendwann eine neuere Version verfügbar war, möglicherweise von einer temporären passenden Quelle, die später auf meinem System entfernt wurde. Ich habe das Problem behoben, indem ich Perl-base auf die Version Perl heruntergestuft habe:

$ Sudo apt install -f Perl-base=5.22.1-9

Danach wird Git richtig installiert. Für den Fall, dass eine neuere Perl-Basisversion verfügbar war, habe ich versucht, diese zu aktualisieren, aber die obige Version war auch die neueste Version:

$ Sudo apt install Perl-base=\*
Perl-base is already the newest version (5.22.1-9).
Selected version '5.22.1-9' (Ubuntu:16.04/xenial [AMD64]) for 'Perl-base'

Soweit ich weiß sollte dies keine Probleme verursachen, aber YMMV.

1
Ferry Boender