it-swarm.com.de

Installieren der Ubuntu 16.04-Treiber für Nvidia Geforce 820M

Ich besitze einen Lenovo Z50-70-Laptop mit Intel Integrated Graphics und einem Nvidia Geforce 820M. Seit ich Ubuntu 16.04 installiert habe, wurde die Grafikkarte nicht mehr verwendet. Ich habe versucht, alles, was mit Nvidia zu tun hat, zu deinstallieren und nvidia-375 erneut zu installieren, was dann erklärt, dass es von libc6-i386 abhängt, das dann zurückkehrt

The following packages have unmet dependencies.
 libc6-i386 : Depends: libc6 (= 2.23-0ubuntu3) but 2.23-0ubuntu5 is to be installed
E: Unable to correct problems, you have held broken packages.

Wenn ich versuche, libc6 zu installieren, erhalte ich libc6 is already the newest version (2.23-0ubuntu5).

Wie installiere ich diese oder gibt es eine andere Möglichkeit, um meine Grafikkarte zum Laufen zu bringen?

In Bezug auf andere Befehle:

lspci -vnn | grep 3D -A 12 gibt zurück:

03:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)
Subsystem: Lenovo GeForce 820M [17aa:380d]
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at c2000000 (32-bit, non-prefetchable) [size=16M]
Memory at b0000000 (64-bit, prefetchable) [size=256M]
Memory at c0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 3000 [size=128]
Expansion ROM at <ignored> [disabled]
Capabilities: <access denied>
Kernel driver in use: nouveau
Kernel modules: nvidiafb, nouveau

cat /etc/apt/sources.list gibt zurück:

deb http://archive.ubuntu.com/ubuntu xenial main universe
# deb-src http://archive.ubuntu.com/ubuntu xenial universe
  1. Der Nvidia-Adapter wird angezeigt, wenn Sie anstelle von grep VGAgrep 3D verwenden.

  2. nvidia-340 ist für diesen Adapter falsch. Installieren Sie nvidia-375.

Sie haben nur main und universe Repos verbunden. Gehen Sie zu Systemeinstellungen -> Software & Updates und aktivieren Sie alle anderen Repos, insbesondere restricted. xenial-updates ist ebenfalls nicht verbunden. Sie müssen es auch aktivieren.

Möglicherweise müssen Sie das System aktualisieren, bevor Sie den Treiber installieren.

2
Pilot6