it-swarm.com.de

Ich erhalte immer wieder den Fehler DNS_PROBE_FINISHED_BAD_CONFIG. Wie kann ich das beheben?

Ich habe dies gesehen Frage und versuchte die Antwort am Ende der Seite gestern und es schien zu funktionieren. Aber dann bin ich heute aufgewacht und hatte über eine Stunde lang den gleichen DNS_PROBE_FINISHED_BAD_CONFIG-Fehler. Also habe ich diese Lösung unten noch einmal ausprobiert und es scheint zu funktionieren, aber nur für den Fall, dass ich einen Account erstellt habe und diese Frage stelle. Ich habe die Antwort auch mit 26 Likes versucht, bin aber auf ein Problem gestoßen. Ich habe Sudo rm /etc/resolv.conf in mein Terminal eingefügt und nachdem ich mein Passwort eingegeben habe, ist nichts passiert.

EDIT: Der Fehler ist erneut aufgetreten, als ich versucht habe, dies zu posten. Ich benutze jetzt eine Kabelverbindung.

enp3s0    Link encap:Ethernet  HWaddr 00:26:2d:ad:4e:4c  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:2650 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3087 errors:0 dropped:0 overruns:0 carrier:2
      collisions:0 txqueuelen:1000 
      RX bytes:1617267 (1.6 MB)  TX bytes:581129 (581.1 KB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:11404 errors:0 dropped:0 overruns:0 frame:0
      TX packets:11404 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:907993 (907.9 KB)  TX bytes:907993 (907.9 KB)

wlp6s0    Link encap:Ethernet  HWaddr 78:e4:00:eb:df:96  
      inet addr:192.168.0.20  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::b01:f3f0:11f8:cedd/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:41203 errors:0 dropped:0 overruns:0 frame:0
      TX packets:30797 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:39196701 (39.1 MB)  TX bytes:6166586 (6.1 MB)

Als ich ls/run/resolvconf/interface/in das Terminal eingefügt habe, habe ich NetworkManager bekommen.

BEARBEITEN von Kommentaren: Ich habe ein Modem von ubee, es ist DDW365

Von "127.0.0.1 localhost" bis "ff02 :: 2 ip6-allrouters" war alles in meiner hosts-Datei enthalten.

127.0.0.1   localhost

127.0.1.1   aaron-Aspire-One-721

#The following lines are desirable for IPv6 capable hosts

::1     ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

Dies ist aus meiner Host.conf-Datei:

 # The "order" line is only used by old versions of the C library.
    order hosts,bind
    multi on

Keiner meiner DNS stimmt hier mit dem DNS überein.

Mein WAN

IPv4 DNS Servers:   68.105.28.11
        68.105.29.11
        68.105.28.12

Ausgabe von nmcli device show

GENERAL.DEVICE:                         wlp6s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         78:E4:00:EB:DF:96
GENERAL.MTU:                            0
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     DDW365.51939A-2.4G
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/8
IP4.ADDRESS[1]:                         192.168.0.20/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             68.105.28.11
IP4.DNS[2]:                             68.105.29.11
IP4.DNS[3]:                             68.105.28.12
IP6.ADDRESS[1]:                         fe80::b01:f3f0:11f8:cedd/64
IP6.GATEWAY:                            

GENERAL.DEVICE:                         enp3s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         00:26:2D:AD:4E:4C
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
WIRED-PROPERTIES.CARRIER:               off

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         127.0.0.1/8
IP4.GATEWAY:                            
IP6.ADDRESS[1]:                         ::1/12
2
BlackTunicLink

Versuchen

Sudo dhclient -r interfacename
Sudo dhclient interfacename

wo der Name deiner Schnittstelle ist (meins ist eth0)

Dadurch wird Ihre IP-Adresse freigegeben und erneuert.

Wenn dies nicht hilft, sind die von Ihnen verwendeten COX-DNS-Server möglicherweise überlastet. Dies ist besonders wahrscheinlich, wenn dies ein zeitweise auftretendes Problem ist.

Google Public DNS betreibt rekursive Nameserver für die öffentliche Nutzung unter den folgenden IP-Adressen: 8.8.8.8 und 8.8.4.4 für IPv4-Dienste sowie 2001: 4860: 4860 :: 8888 und 2001: 4860: 4860 :: 8844 für IPv6 Zugriff. Die Adressen werden durch Anycast-Routing dem nächstgelegenen operativen Server zugeordnet. Ich schlage vor, Sie versuchen diese und sehen, ob Sie bessere Ergebnisse erzielen.

Ich habe festgestellt, dass 8.8.8.8 sehr reaktionsschnell ist. Öffnen Sie Netzwerkverbindungen und bearbeiten Sie Ihre Einträge wie unten gezeigt. Klicken Sie dann auf Speichern. Dies sollte das Problem beheben.

EditDNS

4
Elder Geek