it-swarm.com.de

GDAL-Installation schlägt unter Ubuntu 16.04 LTS fehl

Ich versuche, GDAL 2.0 unter Ubuntu 16.04 zu installieren.

Hier ist die Befehlsfolge, die ich versuche:

Sudo apt-get build-dep gdal
cd /tmp 
wget http://download.osgeo.org/gdal/2.0.0/gdal-2.0.0.tar.gz 
tar -xzvf gdal-2.0.0.tar.gz
cd gdal-2.0.0
./configure
make

Und an diesem Punkt scheitert es mit dem Fehler "Speichergröße von sHints ist nicht bekannt":

gdalserver.c: In function 'CreateSocketAndBindAndListen':
gdalserver.c:124:21: error: storage size of 'sHints' isn't known
     struct addrinfo sHints;
                     ^
gdalserver.c:126:31: error: invalid application of 'sizeof' to incomplete type 'struct addrinfo'
     memset(&sHints, 0, sizeof(struct addrinfo));
                               ^
gdalserver.c:129:23: error: 'AI_PASSIVE' undeclared (first use in this function)
     sHints.ai_flags = AI_PASSIVE;
                       ^
gdalserver.c:129:23: note: each undeclared identifier is reported only once for each function it appears in
gdalserver.c:132:12: warning: implicit declaration of function 'getaddrinfo' [-Wimplicit-function-declaration]
     nRet = getaddrinfo(NULL, pszService, &sHints, &psResults);
            ^
gdalserver.c:135:48: warning: implicit declaration of function 'gai_strerror' [-Wimplicit-function-declaration]
         fprintf(stderr, "getaddrinfo(): %s\n", gai_strerror(nRet));
                                                ^
gdalserver.c:135:25: warning: format '%s' expects argument of type 'char *', but argument 3 has type 'int' [-Wformat=]
         fprintf(stderr, "getaddrinfo(): %s\n", gai_strerror(nRet));
                         ^
gdalserver.c:141:39: error: dereferencing pointer to incomplete type 'struct addrinfo'
          psResultsIter = psResultsIter->ai_next)
                                       ^
gdalserver.c:162:5: warning: implicit declaration of function 'freeaddrinfo' [-Wimplicit-function-declaration]
     freeaddrinfo(psResults);
     ^
gdalserver.c:124:21: warning: unused variable 'sHints' [-Wunused-variable]
     struct addrinfo sHints;
                     ^
../GDALmake.opt:579: recipe for target 'gdalserver.lo' failed
make[1]: *** [gdalserver.lo] Error 1
make[1]: Leaving directory '/tmp/gdal-2.0.0/apps'
GNUmakefile:67: recipe for target 'apps-target' failed
make: *** [apps-target] Error 2

Ich habe alle Ratschläge gegoogelt und befolgt, einschließlich der Installation von mehr als 20 Paketen, von denen ich bezweifle, dass ich sie überhaupt benötige. Ich habe es auch mit ./configure --with-python versucht. Hinweis: Ich konnte zuvor GDAL 2.0 erfolgreich auf Ubuntu 14.04 installieren.

2
bozdoz

Ich fand, dass es einen Fehler in 2.0.0 gab und dass ich 2.1.0 installieren musste. Ich habe gerade die Versionsnummern getauscht und es funktioniert super!

3
bozdoz