it-swarm.com.de

Fehler beim Laden der gemeinsam genutzten Bibliotheken: libssl.so.0.9.8: Datei mit gemeinsam genutzten Objekten kann nicht geöffnet werden: Keine solche Datei oder kein solches Verzeichnis

Ich versuche, ncl auf meinem Ubuntu 16.04 64-Bit zu installieren. Nach Abschluss aller Installationsvorgänge gibt das Terminal folgende Fehlermeldung aus:

**ncl: error while loading shared libraries: libssl.so.0.9.8: cannot
open shared object file: No such file or directory.**

und nach dem Ausführen von * Sudo apt-get install libssl.so.0.9.8 * wird mir mitgeteilt, dass kein solches Paket gefunden werden konnte. Wie kann ich das beheben? Danke!

3
Lirui

Was auch immer ncl ist (ich nehme an, es ist eine Art proprietäre Software), es scheint, dass es mit einer alten Version von libssl verbunden ist. Natürlich werden Sie diese alte Version der Bibliothek auf Ihrem Ubuntu sicher nicht finden.

Sie können jedoch versuchen, einen Symlink mit dem entsprechenden Namen zu erstellen, der auf Ihre "echte" libssl verweist. Dazu müssen Sie jedoch einige Tricks mit der Befehlszeile ausführen.

Führen Sie Folgendes aus: Sudo ls /lib/x86_64-linux-gnu/libssl*

Das wird etwas in Übereinstimmung mit /lib/x86_64-linux-gnu/libssl.so.1.0.0 zurückgeben

Beachten Sie den Teil "libssl.so.1.0.0", oder dieser Name kann in Ihrer Installation abweichen.

Geben Sie nun diesen Befehl ein: Sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /lib/x86_64-linux-gnu/libssl.so.0.9.8

Ändern Sie die "libssl.so.1.0.0" zu dem, was Sie in Ihrem System gefunden haben.

Nachdem Sie fertig sind, versuchen Sie, das verdammte "ncl" auszuführen. :)

BEARBEITEN: Das Beste ist, dass Sie versuchen können, das libssl-Paket von einer älteren Ubuntu-Version wie 14.04 zu installieren.

Laden Sie zuerst das libssl-0.9.8 -Paket von der Ubuntu 14.04-Version herunter:

wget http://security.ubuntu.com/ubuntu/pool/universe/o/openssl098‌/libssl0.9.8_0.9.8o-‌​7ubuntu3.2.14.04.1_a‌​md64.deb

Dann installieren Sie es einfach:

Sudo dpkg -i libssl0.9.8_0.9.8o-7ubuntu3.2.14.04.1_AMD64.deb

Dies sollte den Trick machen.

1
Alvils Berzins