it-swarm.com.de

Fehler bei der Installation von MySQL-Server in Ubuntu 16.04

Wenn ich mysql-server installiere, erhalte ich folgende Fehlermeldung:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-server : Depends: mysql-server-5.7 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ich kann den mysql-client jedoch problemlos installieren. Ich habe alle Lösungen für verwandte Fragen ausprobiert, aber nichts hat funktioniert. Die damit verbundenen Probleme, die ich versucht habe, sind:

Die folgende Frage passt auch nicht zu meinem Problem: Fehler bei der Installation von Mysql-Server in Ubuntu16.04

Könnte mir jemand helfen, dieses Problem zu beheben. Danke im Voraus.

3
Gobinath

Schließlich fand ich eine Lösung von dieser Seite .

Deinstallieren Sie, wie in anderen Antworten angegeben, alle vorhandenen mysql-Module. Verwenden Sie den folgenden Befehl, um die Liste der installierten mysql-Module abzurufen:

dpkg -l | grep mysql

Laden Sie den mysql-apt-config_0.7.3-1_all.deb von der MySQL-Website herunter .

Installieren Sie das Paket mit dem folgenden Befehl:

Sudo dpkg -i mysql-apt-config_0.7.3-1_all.deb

Erstellen Sie eine neue Datei /etc/apt/preferences.d/mysql mit diesem Inhalt

Package: *
Pin: Origin "repo.mysql.com"
Pin-Priority: 999

Führen Sie den folgenden Befehl aus, um den Cache zu aktualisieren

Sudo apt update

Führen Sie den folgenden Befehl aus, um MySQL zu installieren

Sudo apt install mysql-client mysql-server libmysqlclient-dev
3
Gobinath