it-swarm.com.de

Abspielen von FLV-Videos in Ubuntu 16.04: Welche Pakete (gstreamer?) Muss ich installieren, damit Totem fehlerfrei funktioniert?

Ich dachte, ich hätte jetzt alle "proprietären" Codecs durch Doppelklicken auf einige meiner Videos installiert, und Totem bat mich, Pakete zu installieren. Es gibt jedoch eine Art von Videos, die mich nicht zur Installation von Paketen auffordern und nicht von Totem abgespielt werden (sie funktionierten früher mit früheren Ubuntu-Versionen, ich erinnere mich nicht, wie). Sie geben nur den Fehler Internal data stream error aus. , und nichts wird in der Konsole gedruckt, wenn ich Totem davon starte.

Wie installiere ich flv Codecs für Totem in Ubuntu 16.04 LTS?

Ich habe Folgendes versucht:

$ Sudo apt install gstreamer1.0-*

Es gibt jedoch diesen Fehler:

Building dependency tree       
Reading state information... Done
Note, selecting 'gstreamer1.0-plugins-ugly-amr' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-videosink' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-alsa' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-ugly-dbg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-ugly-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-base-apps' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-hybris:i386' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-tools' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-good' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-qapt' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-espeak' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-Nice' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-videosource' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-crystalhd' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-fluendo-mp3' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-bad' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-base' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-audiosource' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-bad-videoparsers' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-really-bad' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-clutter' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-pulseaudio' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-pocketsphinx' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-bad-dbg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-bad-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-visualization' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-bad-faad' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-lame' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-x' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-vaapi-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-libav' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-base-dbg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-good-dbg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-base-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-good-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-dvswitch' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-clutter-3.0' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-vaapi' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-libav-dbg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-packagekit' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-ffmpeg' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-plugins-ugly' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-doc' for glob 'gstreamer1.0-*'
Note, selecting 'gstreamer1.0-audiosink' for glob 'gstreamer1.0-*'
gstreamer1.0-clutter-3.0 is already the newest version (3.0.18-1).
gstreamer1.0-clutter-3.0 set to manually installed.
gstreamer1.0-plugins-ugly is already the newest version (1.8.0-1ubuntu1).
gstreamer1.0-plugins-ugly-amr is already the newest version (1.8.0-1ubuntu1).
gstreamer1.0-plugins-ugly-amr set to manually installed.
gstreamer1.0-plugins-base is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-plugins-base set to manually installed.
gstreamer1.0-libav is already the newest version (1.8.1-1~ubuntu1).
gstreamer1.0-pulseaudio is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-pulseaudio set to manually installed.
gstreamer1.0-tools is already the newest version (1.8.1-1~ubuntu1).
gstreamer1.0-tools set to manually installed.
gstreamer1.0-plugins-base-apps is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-plugins-base-apps set to manually installed.
gstreamer1.0-plugins-good is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-plugins-good set to manually installed.
gstreamer1.0-x is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-x set to manually installed.
gstreamer1.0-alsa is already the newest version (1.8.1-1ubuntu0.1).
gstreamer1.0-alsa set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer1.0-hybris:i386 : Depends: libgstreamer-plugins-bad1.0-0:i386 (>= 1.8.0) but it is not going to be installed
                            Depends: libgstreamer-plugins-bad1.0-0:i386 (< 1.8.1) but it is not going to be installed
                            Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                            Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                            Depends: libmedia1:i386 but it is not going to be installed
 gstreamer1.0-libav-dbg : Depends: gstreamer1.0-libav (= 1.8.0-1) but 1.8.1-1~ubuntu1 is to be installed
 gstreamer1.0-plugins-base-dbg : Depends: gstreamer1.0-alsa (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
                                 Depends: gstreamer1.0-plugins-base (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
                                 Depends: gstreamer1.0-x (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
                                 Depends: libgstreamer-plugins-base1.0-0 (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
 gstreamer1.0-plugins-good-dbg : Depends: gstreamer1.0-plugins-good (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
                                 Depends: gstreamer1.0-pulseaudio (= 1.8.0-1ubuntu1) but 1.8.1-1ubuntu0.1 is to be installed
 gstreamer1.0-vaapi : Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
                      Depends: libva-wayland1 (>= 1.3.0) but it is not going to be installed
                      Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Vielen Dank

2
knocte

Ok, die Installation dieses Programms hat das Problem behoben:

Sudo apt install gstreamer1.0-vaapi
4
knocte