it-swarm.com.de

.cache / upstart / Unity7.log wächst, um den gesamten freien Speicherplatz zu belegen. Python Verschlüsselung vermutet

~/.cache/upstart/unity7.log nimmt zu und verbraucht in 7-10 Stunden die gesamte Festplatte ~ 130GB.

Wenn ich die Datei beschreibe, erhalte ich:

[email protected]:~/.cache/upstart$ tail -f unity7.log
extern "Python": function Cryptography_Rand_bytes() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.
extern "Python": function Cryptography_Rand_status() called, but @ffi.def_extern() was not called in the current subinterpreter.  Returning 0.

Ich finde Gemeinsamkeiten mit Kodi.bin (v.17), kann aber noch nicht sagen, ob dies qualitativ oder quantitativ ist. Ich würde mich über Tipps zur Fehlerbehebung oder bekannte Fehler freuen :)

3
RMJ

Das manuelle Herunterladen und Installieren von python-cryptography und python-openssl aus dem Ubuntu-Paket-Repository ist möglicherweise eine sicherere Alternative zum Hinzufügen des Repositorys für eine zukünftige Verteilung zu Ihrer Quellliste.

Ich habe dies erreicht, indem ich die entsprechenden Pakete von hier und hier heruntergeladen und sie dann mit dpkg installiert habe:

Sudo dpkg -i python-cryptography_1.7.1-2_AMD64.deb
Sudo dpkg -i python-openssl_16.2.0-1_all.deb
Sudo apt-get -f install

Wichtig: Lesen Sie die Ausgabe des letzten Befehls sorgfältig durch. Es drohte, eine Menge Pakete zu entfernen, als ich es ausführte, da Abhängigkeiten nicht erfüllt wurden - ich habe anfangs versucht, python-openssl ohne python-cryptography zu installieren.

Weitere Informationen zum manuellen Installieren von Paketen finden Sie hier: Wie installiere ich eine .deb-Datei über die Befehlszeile?

Nach einem Neustart vergrößert sich meine Unity-Protokolldatei nicht mehr mit einer Geschwindigkeit von 10 MB pro Sekunde.

1
Jonathan Holvey

Einen bekannten Fehler gefunden, muss python-openssl aktualisiert werden.

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/163657 , wird zurückmelden.

Bearbeiten: Durch Aktualisieren von python crypto wird das Problem behoben :)

Sie können Python-Cryptography Version 1.7.1-2 und Python-Openssl Version 16.2.0-1 von der Distribution Zesty (Ubuntu 17.04) installieren. Was ich getan habe:

/etc/apt/sources.list bearbeiten:

Hinzufügen:

#Zesty
deb http://se.archive.ubuntu.com/ubuntu zesty main 
deb-src http://se.archive.ubuntu.com/ubuntu zesty main

(Für Schweden können Sie natürlich in das Repository Ihres Landes wechseln, erste Buchstaben nach http://)

Sudo aptitude update
Sudo aptitude install python-cryptography=1.7.1-2

Dadurch wird auch python-openssl auf die neueste Version aktualisiert

0
RMJ