it-swarm.com.de

Wie installiere ich openjfx unter Ubuntu 14.04 / Linux Mint 17?

Es scheint, dass Versuche, OpenJFX (libopenjfx-Java) auf Ubuntu 14.04/Linux Mint 17 zurück zu portieren, ins Stocken geraten sind (siehe Fehler unten). Dieses Paket wird von vielen Projekten mit JDK 8 benötigt. Wie kann ich es auf meinem System installieren?

Verwandte Fehler:

2
Jonathan Cross

Binärdateien sind für diese älteren Systeme nicht verfügbar, Sie können sie jedoch aus dem Quellcode kompilieren:

Sudo apt-get build-dep libopenjfx-Java
Sudo apt-get --compile source libopenjfx-Java

Sie können die Pakete dann installieren, indem Sie auf jede zu installierende Deb-Datei doppelklicken:

libopenjfx-jni_8u60-b27-4~trusty1_AMD64.deb
libopenjfx-Java_8u60-b27-4~trusty1_all.deb
libopenjfx-Java-doc_8u60-b27-4~trusty1_all.deb
openjfx_8u60-b27-4~trusty1_AMD64.deb
2
Jonathan Cross