it-swarm.com.de

Wie aktualisiere ich mein Git auf die neueste Version?

laufen:
Ubuntu 14.04 vertrauenswürdige 64bit.

Meine aktuelle Version ist:

itamar /v/l/a/lists λ git --version
git version 1.9.1

Ich habe versucht: Sudo apt-get update; Sudo apt-get install git und es hat nicht funktioniert.

Ich habe versucht: Sudo apt-get purge git; Sudo apt-get install git und trotzdem 1.9.1 installiert.

nicht nur das, irgendwie hat es Atom und Nylas zusammen mit git und einigen anderen git-bezogenen Paketen deinstalliert. Ich würde gerne wissen, warum es das auch tat. Unten sehen Sie die Ausgabe des Löschvorgangs.

itamar ~ λ Sudo apt-get purge git
[Sudo] password for itamar: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
atom* git* git-cola* git-core* gitk* nylas*
0 upgraded, 0 newly installed, 6 to remove and 0 not upgraded.
After this operation, 543 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 332614 files and directories currently      installed.)
Removing atom (1.8.0) ...
dpkg: warning: while removing atom, directory    '/usr/share/atom/resources/app/apm' not empty so not removed
Removing nylas (0.4.49) ...
Purging configuration files for nylas (0.4.49) ...
Removing git-cola (1.9.3-1) ...
Purging configuration files for git-cola (1.9.3-1) ...
Removing gitk (1:1.9.1-1ubuntu0.3) ...
Removing git-core (1:1.9.1-1ubuntu0.3) ...
Removing git (1:1.9.1-1ubuntu0.3) ...
Purging configuration files for git (1:1.9.1-1ubuntu0.3) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
1
Itamar Gronich

Also habe ich festgestellt, dass es ein buntu Git Maintainers-Team ppa im Launchpad gibt.
Scheint legitim und es hat funktioniert, mein Idiot ist jetzt 2.9, aber ich verstehe wirklich nicht, warum dies überhaupt nicht in Ubuntu enthalten sein würde? das ist grundlegendes Zeug. Und sag mir nicht, dass es daran liegt, dass ich 14.04 und nicht 16.04 laufe, weil 14.04 immer noch die Mehrheit der Ubuntu-Benutzer ist.

Es ist komisch.

2
Itamar Gronich