it-swarm.com.de

Ubuntu 14.04: Fehler bei "apt-get update": W: Ignorieren Liefert Zeile bei DepCompareOp

Ich erhalte diesen Fehler jedes Mal, wenn ich apt-get update tue.

Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US             
Reading package lists... Done                                                  
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
...
...
...
...
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: You may want to run apt-get update to correct these problems

Dieser Fehler wurde nach dem Upgrade von LibreOffice 5.2 auf 5.3 mit dem LibreOffice-PPA angezeigt: ppa:libreoffice/ppa.

Die Sache ist, dass alles gut funktioniert. Ich kann das System aktualisieren/upgraden, ich kann Pakete installieren, Pakete löschen usw. Das Problem liegt nur am Fehler.

Ich habe versucht: apt-get autoclean, apt-get clean, apt-get autoremove, apt-get install -f und viele andere Dinge und nichts beseitigt diesen hässlichen Fehler.

10
Carlos Estrada

Laut Fehlerbericht # 1662227 bietet der PPA für LibreOffice keine Übersetzungsdateien für andere Sprachen als Englisch.

Du kannst entweder

  1. ignorieren Sie diese Warnmeldung sicher als meist kosmetisches Problem oder
  2. entfernen/Deaktivieren Sie die LibreOffice-PPA und verwenden Sie stattdessen die Pakete aus den Repositorys von Canonical.
3
David Foerster

Anstatt von PPA herunterzuladen, können Sie versuchen, es mit snap zu installieren.

Sudo snap install libreoffice

snap-Pakete in 14.04 ausführen zu aktivieren

Sudo apt-get install snapd

Quellen: libreoffice 5.3 snap package , snap in Ubuntu 14.04

Stellen Sie sicher, dass Sie zuerst die vorhandene Installation löschen.

1
Sirajus Salekin

Die Paketbeschreibung in debian/control im PPA ist falsch und besagt, dass die l10n - * - Pakete für 5.3 l10n-5.2 enthalten würden.

Das Paket muss neu aufgebaut werden; Siehe Dieser Ubuntu-Benutzerforum-Beitrag für eine Anleitung.

0
fatabbott