it-swarm.com.de

Ubuntu 14.04, Clang 3.8: Update wegen fehlender libllvm3.8v4 nicht möglich

Ich kann Clang 3.8 auf meinem Ubuntu 14.04-Rechner nicht mehr aktualisieren. Wenn ich apt-get upgrade (oder dist-upgrade) ausführe, schlägt der Paketmanager mit dem folgenden Fehler fehl.

[email protected]:~$ Sudo apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 clang-3.8 : Depends: libllvm3.8v4 but it is not installed
 clang-format-3.8 : Depends: libllvm3.8v4 but it is not installed
 libclang-common-3.8-dev : Depends: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) but it is not installed
 libclang1-3.8 : Depends: libllvm3.8v4 but it is not installed
 liblldb-3.8 : Depends: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) but it is not installed
 lldb-3.8 : Depends: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) but it is not installed
 llvm-3.8 : Depends: libllvm3.8v4 but it is not installed
 llvm-3.8-dev : Depends: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) but it is not installed
 llvm-3.8-runtime : Depends: libllvm3.8v4 but it is not installed
E: Unmet dependencies. Try using -f.

Das Laufen mit -f stoppt hier.

[email protected]:~$ Sudo apt-get dist-upgrade -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libllvm3.8v4
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
9 not fully installed or removed.
Need to get 9721 kB of archives.
After this operation, 40,4 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://si.archive.ubuntu.com/ubuntu/ trusty-updates/main libllvm3.8v4 AMD64 1:3.8-2ubuntu3~trusty4 [9721 kB]
Fetched 9721 kB in 0s (19,8 MB/s)    
(Reading database ... 427368 files and directories currently installed.)
Preparing to unpack .../libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_AMD64.deb ...
Unpacking libllvm3.8v4:AMD64 (1:3.8-2ubuntu3~trusty4) ...
dpkg: error processing archive /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_AMD64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libLLVM-3.8.so.1', which is also in package libllvm3.8:AMD64 1:3.8~svn271772-1~exp1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_AMD64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Das Problem scheint das Paket libllvm3.8v4 zu sein. Demnach , es wurde kürzlich aus dem Haupt-Repository entfernt.

Also dachte ich, ich würde clang 3.8 einfach entfernen und eine andere Version installieren. Aber hier ist der Deal: Mein Paketmanager steckt jetzt fest. Ich kann keine Pakete entfernen oder installieren - einschließlich der llvm und clang. Irgendwelche Ideen?

Noch ein paar Infos

[email protected]:~$ uname -a
Linux window 3.13.0-49-generic #83-Ubuntu SMP Fri Apr 10 20:11:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ dpkg -l | grep -i 'llvm\|clang'
iU  clang-3.8                                             1:3.8-2ubuntu3~trusty4                              AMD64        C, C++ and Objective-C compiler (LLVM based)
iU  clang-format-3.8                                      1:3.8-2ubuntu3~trusty4                              AMD64        Tool to format C/C++/Obj-C code
iU  libclang-common-3.8-dev                               1:3.8-2ubuntu3~trusty4                              AMD64        clang library - Common development package
rc  libclang1-3.4:AMD64                                   1:3.4-1ubuntu3                                      AMD64        C interface to the clang library
rc  libclang1-3.5:AMD64                                   1:3.5-4ubuntu2~trusty2                              AMD64        C interface to the clang library
iU  libclang1-3.8:AMD64                                   1:3.8-2ubuntu3~trusty4                              AMD64        C interface to the clang library
ii  libllvm3.4:AMD64                                      1:3.4-1ubuntu3                                      AMD64        Modular compiler and toolchain technologies, runtime library
ii  libllvm3.4:i386                                       1:3.4-1ubuntu3                                      i386         Modular compiler and toolchain technologies, runtime library
rc  libllvm3.5:AMD64                                      1:3.5-4ubuntu2~trusty2                              AMD64        Modular compiler and toolchain technologies, runtime library
ii  libllvm3.8:AMD64                                      1:3.8~svn271772-1~exp1                              AMD64        Modular compiler and toolchain technologies, runtime library
iU  llvm-3.8                                              1:3.8-2ubuntu3~trusty4                              AMD64        Modular compiler and toolchain technologies
iU  llvm-3.8-dev                                          1:3.8-2ubuntu3~trusty4                              AMD64        Modular compiler and toolchain technologies, libraries and headers
iU  llvm-3.8-runtime                                      1:3.8-2ubuntu3~trusty4                              AMD64        Modular compiler and toolchain technologies, IR interpreter

Außerdem verwende ich das PPA von apt.llvm.org :

[email protected]:~$ tail /etc/apt/sources.list
# Clang 3.8
deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.8 main
deb-src http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.8 main
4
David

Ich habe dieses Problem auch erlebt.

Ich konnte es beheben mit:

    Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_AMD64.deb

dann:

    Sudo apt-get install -f

Fanden die Antwort hier: http://forum.ubuntu-it.org/viewtopic.php?p=4901154

8
creardon