it-swarm.com.de

Qualcomm Atheros Device [168c: 003e] (Version 32) QCA6174 - Probleme nach Kernel- / Firmware-Aktualisierung (4.2.0-18-generic / firmware_1.149.2)

Ich habe kürzlich wegen eines fehlenden WLAN-Treibers (Qualcomm Atheros Device [168c: 003e] - ath10k_pci) auf 4.2.0-18-generic/firmware_1.149.2 aktualisiert.

Das Wifi funktioniert immer noch nicht (auch mit dem Fahrer).

lspci -knn | grep -i Net -A2

rfkill liste

Sudo lshw -C Network

dmesg

07:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 32)
    Subsystem: Lite-On Communications Inc Device [11ad:0807]
    Kernel driver in use: ath10k_pci
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    Subsystem: Acer Incorporated [ALi] Device [1025:1039]
    Kernel driver in use: r8169

0: Acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

 *-network DISABLED      
       description: Wireless interface
       product: Qualcomm Atheros
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:07:00.0
       logical name: wlan0
       version: 32
       serial: b8:86:87:d4:85:c9
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath10k_pci driverversion=4.2.0-18-generic firmware=WLAN.RM.2.0-00180-QCARMSWPZ-1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:128 memory:84000000-841fffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:08:00.0
       logical name: eth0
       version: 15
       serial: 30:65:ec:8d:74:3e
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.16 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:125 ioport:3000(size=256) memory:84204000-84204fff memory:84200000-84203fff



[    1.938579] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
[    1.939384] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
[    1.939387] ath10k_pci 0000:07:00.0: failed to load spec board file, falling back to generic: -2
[    1.939556] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[    1.939557] ath10k_pci 0000:07:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[  149.399331] ath10k_pci 0000:07:00.0: failed to enable dynamic BW: -11
[  152.397362] ath10k_pci 0000:07:00.0: could not suspend target (-11)
[  154.017303] systemd-hostnamed[2521]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

bearbeiten:

Die Firmware-5.bin für QCA6174 wurde nicht in der Datei lib/firmware/ath10k/QCA6174/hw3.0 gefunden. Deshalb habe ich es aus dem hw2.1 Ordner kopiert. Die andere Sache war, dass die ath10k.conf fehlte.

Sudo nano /etc/modprobe.d/ath10k.conf

"options ath10k_core skip_otp=y"

aber nach dem neustart gibt es noch kein wifi.

    dmesg | grep ath10k

    [    1.930806] ath10k_pci 0000:07:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
    [    2.172630] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/cal-pci-0000:07:00.0.bin failed with error -2
    [    2.176584] ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
    [    2.176593] ath10k_pci 0000:07:00.0: failed to load spec board file, falling back to generic: -2
    [    4.573919] ath10k_pci 0000:07:00.0: failed to receive control response completion, polling..
    [    5.573756] ath10k_pci 0000:07:00.0: ctl_resp never came in (-110)
    [    5.573759] ath10k_pci 0000:07:00.0: failed to connect to HTC: -110
    [    5.662962] ath10k_pci 0000:07:00.0: could not init core (-110)
    [    5.662982] ath10k_pci 0000:07:00.0: could not probe fw (-110)


0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: Acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no

       description: Network controller
       product: Qualcomm Atheros
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:07:00.0
       version: 32
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=ath10k_pci latency=0
       resources: irq:126 memory:84000000-841fffff
3
Oliver

Es scheint jetzt eine Antwort zu geben/oder zumindest ein Workaround - hat für mich funktioniert.

Danke an Dennis.

Bitte sehen Sie:

Beitrag # 22

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1520343?comments=all

Achten Sie beim Kopieren nach /lib/firmware/ath10k/QCA6174/hw3.0/ darauf, dass die Namen der Dateien korrekt sind.

3
Oliver