it-swarm.com.de

Pangox-compat kann nicht mit apt-get installiert werden

Ich kann das pangox-compat -Paket (benötigt von meinem Druckertreiber, Canon MF412 ) mit apt-get nicht installieren. Paket existiert und das entsprechende Repo ist aktiviert:

$ apt-cache madison pangox-compat
pangox-compat | 0.0.2-4ubuntu1 | http://archive.ubuntu.com/ubuntu/ trusty/main Sources

$ Sudo apt-get update
[...]
Hit http://archive.ubuntu.com trusty/main Sources
[...]

$ Sudo apt-get install pangox-compat
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package pangox-compat

Ich könnte das Paket herunterladen und mit dpkg installieren, aber ich würde die Verwendung von dpkg und apt-get nicht mischen.

Ich habe Lubuntu 14.04.1

1
Marco Sulla

installiere es über Sudo apt-get install libpangox-1.0-dev

3
  1. Laden Sie das Quellpaket von pangox-compat für 14.04 herunter (Quellpaket: pangox-compat (0.0.2-4ubuntu1)).

    wget http://archive.ubuntu.com/ubuntu/pool/main/p/pangox-compat/pangox-compat_0.0.2.orig.tar.xz  
    
  2. Extrahieren Sie das heruntergeladene Archiv.

    tar -xJvf pangox-compat_0.0.2.orig.tar.xz   
    
  3. Installieren Sie pangox-compat in einem Systemverzeichnis.

    Sudo apt-get install build-essential make    
    cd pangox-compat-0.0.2  
    ./configure  
    make  
    Sudo make install # installs pangox-compat into a system directory  
    
1
karel

pangox-compat ist ein Quellpaket . Die daraus erstellten Binärpakete (die Sie mit apt-get install installieren können) sind libpangox-1.0-0 und libpangox-1.0-dev. Wenn Sie etwas aus dem Quellcode erstellen müssen, installieren Sie libpangox-1.0-dev. Wenn nicht, ist libpangox-1.0-0 ausreichend.

1
muru