it-swarm.com.de

Kein Sound von Chrome, Sound funktioniert einwandfrei in Firefox usw. (13.10)

Ich verwende 13.10 (alles auf dem neuesten Stand) auf einem Lenovo-Laptop mit einem USB-Audiogerät von Griffin iMic. Obwohl ich gelegentlich das Pulse Audio-Lautstärkeregler-Tool verwenden muss, um das iMic erneut auszuwählen, funktioniert es konsistent von allem auf dem System mit Ausnahme von Chrome, was im Grunde genommen der Fall ist hat überhaupt kein audio.

Bei den meisten Anwendungen, die das Audiomaterial verwenden möchten, sehen Sie etwas in der ersten Registerkarte von pavucontrol. Nicht Chrome; da ist einfach nichts.

Einige alte Forenbeiträge hier und da schlugen vor, das Firefox-Verzeichnis "plugins" mit dem Installationsverzeichnis von Chrome zu verknüpfen, was ziemlich doof zu sein scheint und jetzt sowieso nicht funktioniert.

Chrome-Version ist 34.0.1847.132.

Gibt es einen Trick, um Chrome mit einem USB-Audiogerät arbeiten zu lassen? (Soweit ich das beurteilen kann, funktioniert es auch nicht mit eingebautem Audio ...)

edit - Funktioniert immer noch nicht, jetzt auf 14.04 und Chrome 37.0.2062.120

Mehr Info:

Chrome wurde mehrmals ohne Auswirkung neu installiert. Ich habe auch die Beta ausprobiert (derzeit Chrome 38.0.2125.77 Beta). Das PulseAudio-Manager-Tool zeigt in seiner Client-Liste Firefox und verschiedene andere Dinge sowie "Chrome-Eingabe", aber keine "Chrome-Ausgabe".

Chrom verhält sich genauso.

edit - jetzt auf einer (alten und müden) 15.04 Installation. Chrome (Version 49.0.2623.112 (64-bit)) funktioniert immer noch nicht , obwohl es in Vollmondnächten oder anderen zufälligen Situationen gesendet wird Ton über das eingebaute analoge Audio auf dem Laptop. Chromium (Version 48.0.2564.82 Ubuntu 15.04 (64-bit)) funktioniert jetzt und über das USB-Audiogerät. Ich weiß nichts Bestimmtes, was ich in letzter Zeit getan habe, um das zu verwirklichen, aber

42
Pointy

Ich hatte das gleiche problem Schließlich versuchte mein System, den Sound von Chrome über HDMI zu übertragen, obwohl der HDMI-Akkord zu diesem Zeitpunkt nicht eingesteckt war. Vermutlich könnte dies bei jedem Audio-Ausgabegerät passieren. Die Soundeinstellungen, die Ubuntu anbietet, haben dies nicht gezeigt und ich habe es nicht für die einzelne Anwendung ändern lassen, aber pavucontrol hat es getan.

So installieren Sie pavucontrol vom Terminal aus:

Sudo apt-get install pavucontrol

So öffnen Sie pavucontrol vom Terminal aus:

pavucontrol

Wählen Sie das Menü "Wiedergabe" und vergewissern Sie sich, dass "Programme anzeigen" ausgewählt ist. Spielen Sie jetzt etwas von Google Chrome. Dort wird angezeigt, welches Ausgabegerät für Google Chrome verwendet wird. Stellen Sie sicher, dass es auf das Ausgabegerät eingestellt ist, das Sie verwenden möchten.

59
Colonel Trogdor

Diese Arbeit für mich (Ubuntu 14.04):

killall pulseaudio
rm -r ~/.config/Pulse/*
rm -r ~/.Pulse*

Und neu starten.

Diese Befehle stoppen pulseaudio und entfernen die aktuelle Konfiguration, um wieder mit den Standardeinstellungen zu beginnen.

46
ONe Zetty

Führen Sie folgende Befehle aus:

killall pulseaudio
rm -r ~/.config/Pulse/*
rm -r ~/.Pulse*

Starten Sie das System neu.

6
Daniel N

Versuchen Sie Folgendes, bevor Sie das gesamte Konfigurationsverzeichnis Chrome löschen: Wechseln Sie zu einem anderen Audioausgabegerät, und kehren Sie dann zum ursprünglichen Gerät zurück. Wenn Sie nur ein Audiogerät haben, schließen Sie ein externes an (z. B. HDMI- oder USB-Audio) und führen Sie dann den obigen Trick aus.

pdate Folgendes scheint zu verhindern, dass das Problem in Zukunft erneut auftritt:

  • Bearbeiten Sie /etc/Pulse/default.pa, suchen Sie die Zeile, die mit load-module module-stream-restore beginnt, und fügen Sie restore_device=false am Ende hinzu, sodass die Zeile wie folgt aussieht:

    load-module module-stream-restore restore_device=false

  • Mach killall pulseaudio

3
revl

Ich hatte ein ähnliches Problem. Mein Laptop hatte zwei Soundkarten, eine für den eingebauten Ton aus den Laptop-Lautsprechern, die andere für den HDMI-Ausgang. Wenn ich Musik abspielte oder etwas, das den Sound des Browsers verwendete, kanalisierte es den Sound über den HDMI-Kanal. Im kmix-Sound-Manager konnte ich sehen, dass chrome in den Wiedergabestreams aufgeführt ist. Wenn Sie jedoch mit der rechten Maustaste auf das Symbol chrome geklickt und Verschieben ausgewählt haben, gab es eine Option zum Ändern des Audios Ausgabe für den Stream. Ich stellte sicher, dass es kein HDMI war, da ich wollte, dass der Ton aus meinen Lautsprechern oder Kopfhörern kommt.

2
Juan

Keine der oben genannten Formen funktioniert, seit einer Woche ohne Ton in chrome. Dann habe ich SMplayer gestartet, auch kein Ton, Optionen> Einstellungen> Audio von pulseaudio auf alsa umgestellt.

Das nächste Mal habe ich chrome Sound gestartet.

2

Überprüfen Sie, ob Sie die richtige Chrome-Architektur verwenden.

Ich hatte i386 Chrome auf einem 64-Bit-System installiert und hatte dieses Problem. Als ich die 64-Bit-Version deinstallierte und installierte, funktionierte Audio einwandfrei.

1
Alex

Chrome wird mit einem integrierten Flash-Player geliefert und funktioniert nicht immer gut.

Wenn Sie mit Firefox Sound auf Websites wie YouTube oder Deezer haben, haben Sie möglicherweise bereits einen Flash-Player auf Ihrem System: das Paket "flashplugin-installer".

Wenn nicht:

Sudo apt-get install flashplugin-installer

Anschließend können Sie in den Plugins von Chrome festlegen, welchen Flash Player Sie verwenden möchten:

  • öffne einen neuen Tab und gib chrome: // plugins anstelle einer URL ein
  • klicken Sie auf Details auf der rechten Seite.
  • wählen Sie Adobe Flash Player
  • sie sehen zwei verschiedene "Sub" -Plugins
  • deaktivieren Sie die aktuelle und aktivieren Sie die andere
  • starten Sie Chrome neu

Sie können auch ein kurzes Video darüber finden, wie es unter Chrome für Windows gemacht wird. Dies ist in Ubuntu genauso:
http://youtu.be/cDgwNzEFuFY

1
ttoine

Ich hatte das gleiche Problem, dass Sie möglicherweise nicht sofort nach der Installation eines Chrome-Remote-Desktop-Problems bemerken, nachdem ich meinen PC neu gestartet habe. So funktionierte das Folgen für mich. Ich benutze: Ubuntu 18.04 LTS

  1. Sudo apt-get autoremove chrome-remote-desktop
  2. killall pulseaudio rm -r ~/.config/Pulse/* rm -r ~/.Pulse *

kopieren Sie jede Zeile im Terminal und fügen Sie sie hinzu. Ich hoffe es hilft

0
Afsal

Eine einfache Neuinstallation von Chrome funktionierte für mich unter Ubuntu 14.04.

Sudo apt-get install google-chrome-stable --reinstall

0
Kidquick