it-swarm.com.de

Google Chrome unter Ubuntu 14.04 Desktop kann nicht ausgeführt werden. Fehler beim Initialisieren von NSS mit einer persistenten Datenbank

Zuvor habe ich das Betriebssystem Sudo apt-get dist-upgrade vom Terminal aus ausgeführt. Danach konnte google-chrome-stable nicht mehr ausgeführt werden.

Ich habe google-chrome-stable auf My local neu installiert, aber es ist immer noch ein Fehler, wenn google-chrome-stable ausgeführt wird.

Hier Fehler beim Ausführen google-chrome-stable

$ Sudo google-chrome-stable 
[4698:4698:0731/160305:ERROR:nss_util.cc(712)] Error initializing NSS with a persistent database (sql:/home/sts/.pki/nssdb): libsoftokn3.so: cannot open shared object file: No such file or directory
[4698:4698:0731/160305:ERROR:nss_util.cc(207)] Error initializing NSS without a persistent database: NSS error code: -5925
[4698:4698:0731/160305:FATAL:nss_util.cc(209)] nss_error=-5925, os_error=0

Ich bin bereits von Link gelesen, aber nicht für mich zu lösen -_-

Google Chrome Fehler: Fehler beim Initialisieren von NSS ohne persistente Datenbank

Google Chrome: Fehler beim Initialisieren von NSS ohne persistente Datenbank

Kann mir bei diesem Problem weiterhelfen? Ihre Hilfe wird gerne in Anspruch genommen.

1
Yudi Dwiyanto

Ich habe festgestellt, dass libnss3-nssdb entfernt und libnss3 in einem teilweisen Upgrade auf meinem Ubuntu mit Sudo apt-get dist-upgrade aktualisiert wurde.

libnss3-nssdb hängt von libnss3 ab

Jetzt versuche ich libnss3-nssdb zu installieren:

$ Sudo apt-get install libnss3-nssdb
...............................................
The following packages have unmet dependencies:
libnss3-nssdb : Depends: libnss3 (= 2:3.15.4-1ubuntu7) but 2:3.26.2-0ubuntu0.12.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Und ich bekomme das kaputte Paket, wenn es libnss3-nssdb installiert.

E: Sie können Probleme nicht beheben, da Sie defekte Pakete haben.

Rüsten Sie jetzt die Version libnss3-nssdb auf 2: 3.15.4-1ubuntu7 herunter.

Sudo apt install libnss3=2:3.15.4-1ubuntu7

Nach dem Downgrade kann ich chrome Apps auf meinem lokalen Computer ausführen.

Das funktioniert bei mir.

0
Yudi Dwiyanto

Was bei mir funktioniert hat, ist etwas von IKW-Administratoren, das ich unter https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=483774 gefunden habe

Erstellen Sie diese beiden symbolischen Links:

Sudo ln -s /usr/lib/nss/libsoftokn3.so /usr/lib/libsoftokn3.so
Sudo ln -s /usr/lib/nss/libnssdbm3.so /usr/lib/libnssdbm3.so

Jetzt kann ich zumindest Chromium starten und ausführen. Aber ich bin immer noch nicht im Wald. Jetzt misstraut Chromium 100% der SSL-Zertifikate und gibt eine Fehlermeldung aus

FEHLER: cert_verify_proc_nss.cc (974)] CERT_PKIXVerifyCert für update.googleapis.com fehlgeschlagen err = -8179

0
n8chz