it-swarm.com.de

DisplayLink USB 3.0 funktioniert nicht unter Ubuntu 14.04LTS

Mir ist aufgefallen, dass dies möglicherweise ein weiterer DisplayLink-Aufschrei ist - aber ich dachte, ich probiere es trotzdem aus. Also die übliche Geschichte - ich habe einen DisplayLink-Adapter Kensington USB3.0 Video Adapter und sieht nicht so aus, als würde er jemals funktionieren.

Es wird neu organisiert, wenn ich es einstecke.

#uname -r
3.13.0-35-generic

# dmesg

[52049.856134] usb 2-2: new high-speed USB device number 8 using ehci-pci
[52049.989282] usb 2-2: New USB device found, idVendor=17e9, idProduct=430f
[52049.989290] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[52049.989295] usb 2-2: Product: Kensington USB3.0 Video Adapter
[52049.989299] usb 2-2: Manufacturer: DisplayLink
[52049.989304] usb 2-2: SerialNumber: 10024214
[52059.384628] usbcore: registered new interface driver udlfb
[52402.886345] usbcore: deregistering interface driver udlfb
[52418.187053] usbcore: registered new interface driver udlfb
[53522.914146] nouveau E[   PFIFO][0000:01:00.0] CACHE_ERROR - ch 2 [Xorg[1276]] subc 0 mthd 0x0060 data 0xbeef0201

Ich habe udl in /etc/modprobe.d/blacklist-custom.conf auf die schwarze Liste gesetzt und udlfb aus /etc/modprobe.d/blacklist-framebuffer.conf entfernt.

Ich habe auch den udlfb -Treiber manuell geladen.

# modprobe udlfb

[52418.187053] usbcore: registered new interface driver udlfb

Ok, also im Grunde gehe ich damit nicht weiter voran - denn wenn ich es tue;

# ls /dev | grep fb

fb0 ist der einzige gefundene Geräteblock - was mir anzeigt, dass udlfb das Gerät nicht erkennt. udevadm info auf fb0 zeigt - es ist der Hauptbildschirm des Laptops.

# udevadm info -a -p $(udevadm info -q path -n /dev/fb0)

 looking at device '/devices/pci0000:00/0000:00:01.0/0000:01:00.0/graphics/fb0':
    KERNEL=="fb0"
    SUBSYSTEM=="graphics"
    DRIVER==""
    ATTR{pan}=="0,0"
    ATTR{name}=="nouveaufb"
    ATTR{mode}==""
    ATTR{console}==""
    ATTR{blank}==""
    ATTR{modes}=="U:1440x900p-0"
    ATTR{state}=="0"
    ATTR{bits_per_pixel}=="32"
    ATTR{cursor}==""
    ATTR{rotate}=="0"
    ATTR{stride}=="7680"
    ATTR{virtual_size}=="1920,1080"

Ich habe derzeit 1 Anbieter und das ist der Hauptbildschirm.

# xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x65 cap: 0x1, Source Output crtcs: 2 outputs: 4 associated providers: 0 name:nouveau

Beim Durchstöbern von /sys/class/graphics ist fbcon mit folgenden Einstellungen aufgefallen:

  looking at device '/devices/virtual/graphics/fbcon':
    KERNEL=="fbcon"
    SUBSYSTEM=="graphics"
    DRIVER==""
    ATTR{cursor_blink}=="0"
    ATTR{rotate}=="0"

Lassen Sie mich auch erwähnen, dass ich versucht habe, udl mit udlfb ohne Freude auf die schwarze Liste zu setzen.

OK, also lange Rede, kurzer Sinn - Kann irgendjemand einen ähnlichen DisplayLink USB 3.0 Adapter für Ubuntu 14.04 LTS oder ähnliches bekommen?

9
Bitmap

Update August 2015

3 Jahre nach Veröffentlichung des Chipsatzes Displaylink hat Beta-Versionen eines Treibers zur Unterstützung der DL3XXX-Chipgeneration unter Ubuntu 14.04 veröffentlicht . Ich lasse den folgenden Inhalt als ursprüngliche Antwort auf die Fragen.

Bitte sehen Sie:

Alte Informationen unten

Die USB3.0 Displaylink-Geräte unterstützen NICHT Linux

Hierzu gehört insbesondere die Displaylink DL3XXX-Generation und neuer.

Displaylink hat nicht die Absicht, in absehbarer Zukunft einen Fahrer zu machen. Siehe hierzu thread .

Wim von Displaylink schrieb am 17.08.2012:

Wir haben derzeit keine ETAs und suchen noch nach dem besten Weg, dies zu tun. Ein Problem ist, dass der DL-3000 den Schutz von Inhalten unterstützt und wir sicherstellen müssen, dass dies in einer Open Source-Umgebung sicher bleibt.

Dies wurde auch in this answer besprochen. Weitere verwandte Fragen hier: this

BEARBEITEN: Juli 2015

Es scheint, dass die USB3.0-Unterstützung für Linux im dritten Quartal 2015 erscheinen könnte, wie angekündigt hier (Danke, NecLimDul)

8
noleti

Displaylink hat gerade einen Linux-Treiber für USB 3-Geräte veröffentlicht: http://www.displaylink.com/downloads/ubuntu.php

Ich habe es unter Ubuntu 15.04 mit dem USB3-Ethernet/VGA/HDMI-Adapter von Dell getestet und es hat funktioniert, obwohl die erkannte Bildschirmauflösung zu niedrig war. Außerdem muss ich das Installationsskript nach jedem Neustart erneut ausführen

3
Tobias Tebbi