it-swarm.com.de

Abhängigkeit nicht befriedigbarer Fehler bei libdbus

Beim Versuch, ein .deb -Paket zu installieren, wird dieser Fehler angezeigt

Dependency is not satisfiable: libdbus-1-3 (>= 1.9.14)

Versuchte diese Befehle ohne Erfolg:

apt-get clean
apt-get update
apt-get dist-upgrade
apt-get install -f
apt get -a --configure

Ich bin mir nicht sicher, wie ich fortfahren soll

4
user669681

Das Problem ist, dass Ubuntu 14.04 libdbus-1-3 Version 1.6.18 verwendet. Aus diesem Grund können Sie kein Paket installieren, für das 1.9.14 oder höher erforderlich ist.

Eine einfache Lösung ist ein Upgrade auf eine neuere Version von Ubuntu. Beispielsweise verwendet Ubuntu 16.04 libdbus-1-3 Version 1.10.6.

Eine andere einfache Lösung besteht darin, eine ältere Version der zu installierenden Software zu verwenden. Die Anforderung für libdbus-1-3 Version 1.9.14 zeigt an, dass es sich ohnehin nicht um ein aktuell unterstütztes Ubuntu-Repository handelt.

Hier ist eine einfache Möglichkeit, die verschiedenen Versionen der einzelnen Versionen (und des jeweiligen Repositorys) von Ubuntu herauszufinden:

$ rmadison libdbus-1-3
 libdbus-1-3 | 1.4.18-1ubuntu1    | precise          | AMD64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.4.18-1ubuntu1.8  | precise-security | AMD64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.4.18-1ubuntu1.8  | precise-updates  | AMD64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.6.18-0ubuntu4    | trusty           | AMD64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.6.18-0ubuntu4.4  | trusty-security  | AMD64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.6.18-0ubuntu4.5  | trusty-updates   | AMD64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.8.12-1ubuntu5    | vivid            | AMD64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.10.6-1ubuntu3    | xenial           | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.6-1ubuntu3.1  | xenial-security  | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.6-1ubuntu3.3  | xenial-updates   | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1   | yakkety          | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.1 | yakkety-security | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.1 | yakkety-updates  | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.2 | yakkety-proposed | AMD64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu2   | zesty            | AMD64, arm64, armhf, i386, ppc64el, s390x
4
user535733

Versuche dies:

dpkg --force-all -i opera-stable_51.0.2830.55_AMD64.deb 

Der Parameter --force-all installiert das Opera -Paket trotz des Abhängigkeitsproblems. Viel Glück.

3
Vladimir