it-swarm.com.de

Abhängigkeit ist nicht erfüllbar: libglibmm-2.4-1c2a (> = 2.42.0)

Aktualisiert mein MySQL auf 5.6 und in der Folge brach meine bereits vorhandene MySQL-Workbench.

Der Versuch, die neueste mysql-Workbench sowohl vom Software-Manager als auch von der neuesten .deb-Datei von der Downloadseite neu zu installieren:

Dependency is not satisfiable: libglibmm-2.4-1c2a (>= 2.42.0)

Ich arbeite mit 14.04 und habe das Paket hier gefunden:

http://packages.ubuntu.com/trusty/libglibmm-2.4-1c2a

Wieso kann ich mysql workbench nicht installieren? Diese Abhängigkeit scheint im 14.04.

3
Dylan Pierce

Je nachdem, wo Sie das Paket haben, das Sie gerade installieren möchten, haben Sie möglicherweise das falsche - Ihr Paket benötigt die Version (>= 2.42.0) (dh neuer als 2.42), aber die verfügbare vertrauenswürdige Version ist derzeit 2.39). 9 .
Möglicherweise haben Sie versehentlich ein Paket für Utopic oder ein neueres erhalten (möglicherweise über ein installiertes PPA ) , da beide topic und Vivid haben die Version 2.42.0-1 zur Verfügung.

Allerdings scheint dieses Paket von hier nur zu benötigen:

libatkmm-1.6-1 (> = 2.22.1), libc6 (> = 2.14), libcairo2 (> = 1.13.0 ~ 20140204), libcairomm-1.0-1 (> = 1.6.4), libctemplate2, libcurl3 (> = 7.16.2), libexpat1 (> = 2.0.1), libgcc1 (> = 1: 4.1.1), libgdk-pixbuf2.0 > = 2.22.0), libgl1-mesa-glx | libgl1, libglib2.0-0 (> = 2.35.9),
libglibmm-2.4-1c2a (> = 2.36.2) , libgnome-keyring0 (> = 2.22.2), libgtk2.0 -0 (> = 2.24.0), libgtkmm-2.4-1c2a (> = 1: 2.24.0), libncurses5 (> = 5.5-5 ~), libpango-1.0-0 (> = 1.18.0), libpangocairo- 1.0-0 (> = 1.14.0), libpangomm-1.4-1 (> = 2.27.1), libpcre3, libpcrecpp0 (> = 7.7), libpng12-0 (> = 1.2.13-4), libpython2.7 ( > = 2.7), libsigc ++ - 2.0-0c2a (> = 2.0.2), libsqlite3-0 (> = 3.6.0), libstdc ++ 6 (> = 4.6), libtinyxml2.6.2, libuuid1 (> = 2.16), libx11-6, libxml2 (> = 2.7.4), libzip2 (> = 0.10), zlib1g (> = 1: 1.2.0), python-paramiko

Was ab 14.04 verfügbar sein soll - die offizielle Repo-Version von --- (hier benötigt ebenfalls nur libglibmm-2.4-1c2a (>= 2.36.2).

1
Wilf

entfernen Sie Python-Connector-MySQL MySQL-Dienstprogramme Installieren Sie MySQL-Dienstprogramme

dies ist ein Konflikt, der den korrekten Upgrade-Pfad verhindert: python-connector-mysql -> mysql-connector-python

0
Nicholai Bush

Versuchen Sie, dies mit dem Erkennen von Abhängigkeiten zu lösen:

Sudo apt-get -f install 

Aktualisieren und installieren Sie dann neue Pakete

Sudo apt-get update && Sudo apt-get upgrade

Es löste mein Problem mit der gleichen Beschreibung.

Prost :)

0
vooxo