it-swarm.com.de

14.04 -> 16.04 fehlgeschlagen; apt (> = 1.0.1ubuntu2.13) 'ist nicht installiert

(Diese Frage wurde nicht gelöst. Aus Zeitgründen wurde der Computer auf die Werkseinstellungen zurückgesetzt.)

Ich habe versucht, von 14.04 auf 16.04 zu aktualisieren, aber apt hat diesen Fehler ausgegeben:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

Was bedeutet das und wie kann ich das beheben?

Wenn ich den Befehl apt-cache policy apt eingebe

[email protected]:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main AMD64 
Packages

Der Fehler tritt auf, wenn ich den Befehl ausführe:

Sudo do-release-upgrade -d

und es ergibt sich folgendes:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.
57

Ich hatte heute genau das gleiche Problem. Stellen Sie vor dem Upgrade sicher, dass Ihre Version die neueste Ubuntu 14.04-Version ist. (Ubuntu 14.04.4 zu diesem Zeitpunkt)

Meins war wegen eines schlechten Spiegels bei Ubuntu 14.04.3 hängen geblieben.

Also zuerst ausführen:

Sudo apt update
Sudo apt dist-upgrade

Stellen Sie sicher, dass die Version jetzt Ubuntu 14.04.4 ist (Update September 2016: buntu 14.04.5).

cat /etc/lsb-release

Und starte die Ubuntu 16.04 Installation mit

Sudo do-release-upgrade -d
48
cnxsoft

Am besten aktualisieren Sie immer durch die normalen Verfahren von:

Sudo apt update
Sudo apt dist-upgrade

Wenn dies fehlschlägt, können Sie die folgenden Schritte manuell ausführen. Diese Frage ist veraltet, aber Sie können einfach die Versionsnummern ändern, da die Links immer noch gleich sein sollten.

Geben Sie Folgendes ein, um Ihre Version von apt über ein Terminalfenster zu aktualisieren:

Sudo apt-get download apt

wenn dies nicht funktioniert, können Sie es auch mit wget herunterladen, indem Sie die folgende Zeile ausführen:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_AMD64.deb

dann tippe ein

Sudo dpkg -i apt*.deb

Habe das hier auf meinem System ausprobiert. Hier ist die Ausgabe:

[email protected]:~$ Sudo apt-get download apt
[Sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt AMD64 1.0.1ubuntu2.17 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
[email protected]:~$ ls
apt_1.0.1ubuntu2.17_AMD64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
[email protected]:~$ Sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.17_AMD64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

Wenn nach den beschriebenen Schritten ein Fehler aufgrund einer fehlenden dpkg-Abhängigkeit angezeigt wird, wiederholen Sie die Schritte einfach mit dpkg und.

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_AMD64.deb
Sudo dpkg -i dpkg_1.18.24ubuntu1_AMD64.deb

Alle für Ubuntu verfügbaren Pakete finden Sie hier:

http://security.ubuntu.com/ubuntu/pool/main/

10
Terrance

Einfache Lösung ... Was bei mir funktioniert hat ...

Öffnen Sie im Suchfeld Ihren Synaptic Package Manager. Geben Sie "apt" ein, um die aktuell installierte Version von apt anzuzeigen. Nehmen Sie an, dass "1.0.1ubuntu1.13" mit der rechten Maustaste darauf geklickt und zum Aktualisieren markiert wurde. Klicken Sie dann oben auf die Schaltfläche "Anwenden".

nach dem Upgrade ..

Stellen Sie sicher, dass Sie den Synaptic Package Manager schließen, bevor Sie das Programm ausführen

letzter Befehl

Sudo do-release-upgrade  

und es sollte funktionieren ..

0
jax

Ich habe diese Fehlermeldung bekommen und einen sehr einfachen apt-get update apt-get upgrade gelöst. Die anderen Antworten sind absolut ungenau - zum Beispiel die, bei der es darum geht, Ubuntu 14.04.3 auf 14.04.4 über dist-upgrade zu verschieben - aber dist-upgrade wechselt zur nächsten Ubuntu-Version, nicht zu Minderjährigen. Minderjährige sind ohnehin nur eine veröffentlichte Sammlung spezifischer Paketversionen. Wenn Sie Ihre Pakete einfach auf dem neuesten Stand halten, erhalten Sie mindestens diese oder neuere Versionen. Führen Sie dist-upgrade nur aus, wenn Sie wissen, was Sie tun.

0
chx