it-swarm.com.de

Wie installiere ich die neueste Version von VLC (2.1.2) auf Ubuntu 12.04?

Ich muss Videos in Ultra-HD-4K-Definition (3840 × 2160 Pixel) wiedergeben und mein Lieblingsplayer ist VLC.

In Ubuntu 12.04 LTS ist die neueste verfügbare Version von VLC 2.0.8, die diese Art von Videos nicht unterstützt und auf die neueste verfügbare Version von VLC (2.1.2) aktualisiert werden muss.

Wie kann ich die neueste stabile Version von VLC unter Ubuntu 12.04 installieren?

6
lozanotux

Es gibt jetzt eine PPA von Drittanbietern, die die neueste Version von VLC für Ubuntu 12.04, Ubuntu 12.10, Ubuntu 13.04, Ubuntu 13.10 bereitstellt.

Drücken Sie Strg + Alt + T auf der Tastatur, um das Terminal zu öffnen. Führen Sie beim Öffnen die folgenden Befehle nacheinander aus:

Sudo Add-Apt-Repository ppa: djcj/vlc-stable 
 
 Sudo Apt-Get-Update 
 
 Sudo Apt-Get-Install vlc

via: http://ubuntuhandbook.org/index.php/2014/02/install-vlc-2-1-2-ubuntu-12-04/

4
user245979

Überprüfen Sie die offizielle VLC PPA .

Für die aktuelle stabile Version von VLC ist das ppa:videolan/stable-daily

Fügen Sie es Ihrem System hinzu

Sudo add-apt-repository ppa:videolan/stable-daily

Aktualisieren und aktualisieren/installieren Sie VLC

Sudo apt-get update && Sudo apt-get install vlc

Um die neueste Version zu installieren, fügen Sie die täglich aktualisierte hinzu

Sudo add-apt-repository ppa:videolan/master-daily

Hinweis: Der VLC Stable PPA enthält dieselbe Version von Ubuntu 12.04-Repositorys (2.0.8) und der VLC Master PPA enthält 2.2.0 (Entwicklungsversion).

3
Maythux

Ich habe die VLC2.1.5.tar.gz heruntergeladen und in einen Unterordner meines Homedir entpackt. Ich habe die übliche ./configure ausgeführt und musste natürlich alle fehlenden Bibliotheken in Angriff nehmen. Ich ließ Synaptic offen, um nach den fehlenden Dateien zu suchen, installierte das -dev und wiederholte die ./configure, bis ich aufgefordert wurde, das make auszuführen, schloss Synaptic und führte eine sudo make install aus. Es wurde die ausführbare vlc-Verknüpfung erstellt. Ich hatte zwei Versionen von VLC, die, soweit ich sehen kann, beide einwandfrei funktionieren. Auch ich habe (noch) keine Gründe, auf 14.04 zu upgraden. Das Kompilieren nimmt Zeit in Anspruch, aber die Mühe hat sich gelohnt.

Peter

0
Peter

Nate Muench hat seit langem Repos für VLC-Releases gepflegt, die es nicht bis zu den "stabilen" Repos geschafft haben. Derzeit hat er die folgenden, beide mit VLC 2.1.2:

0
aslamK

Die VLC-stabile PPALaunchpad logo enthält nicht die 2.1.2-Version für ein Release außer Trusty, das sich noch in der Entwicklung befindet.

Nach der Beschreibung der PPA ist dies beabsichtigt:

Diese PPA enthält tägliche Builds aus dem neuesten VLC-Wartungszweig.

Diese PPA wird zum Erstellen neuer und zukünftiger Point-Releases von VLC verwendet, die über SRUs (Stable Release Updates) oder Sicherheitsupdates in Ubuntu eingeführt werden können. Sie finden keine Hauptversionsaktualisierungen in dieser PPA (z. B. keine Aktualisierung von 2.1.x auf 2.2.x).

Aus der PPA-Beschreibung Hervorhebung meiner

Möglicherweise müssen Sie ein anderes PPA mit dem neuesten Stall suchen.

Sogar der VLC Download für Ubuntu-Seite gibt keine Anweisungen, um die neueste Version zu erhalten.

Ubuntu enthält die jeweils neueste VLC-Version zum Zeitpunkt des Einfrierens der Ubuntu-Version (normalerweise etwa zwei Monate vor dem offiziellen Ubuntu-Upgrade).
Danach können Sie immer noch Sicherheits- und kritische Fehlerbehebungen erhalten, aber bis zur nächsten Ubuntu-Veröffentlichung keine weiteren wichtigen VLC-Versionsaktualisierungen.

Wenn Sie eine neuere Version benötigen, sollten Sie ein Upgrade von Ubuntu in Betracht ziehen.

Von VLC Media Player für Ubunt


Manuelles Kompilieren

Dies ist nicht der beste Weg, es sei denn, Sie benötigen wirklich die neueste Version, und Sie sollten nur mit der älteren und stabilen Version zufrieden sein.

Sie können versuchen, den Quellcode von hier herunterzuladen, zu kompilieren und dann zu installieren, wenn Sie dies wünschen.

Laden Sie die Quelldatei tar.xz herunter, es sollte eine README mit Anweisungen geben.

0
kiri