it-swarm.com.de

Installieren Sie Eclipse CDT unter Ubuntu 12.04

Ich versuche, das CDT zu einer vorhandenen Eclipse JDT-Installation hinzuzufügen.

Ich verfolge den folgenden Prozess:

  1. Öffnen Sie Eclipse
  2. Hilfe-> Neue Software installieren
  3. Ich klicke auf die Schaltfläche Hinzufügen
  4. Ich gebe CDT als Namen und den Link http://download.Eclipse.org/tools/cdt/releases/juno als Speicherort für die Repositorys ein. (Übrigens tritt der gleiche Fehler auf, wenn ich versuche, ein lokales Archiv hinzuzufügen, nachdem ich es von der Eclipse-Site heruntergeladen habe - CDT-Master )
  5. Ich wähle sowohl CDT MAIN- als auch CDT OPTIONAL-Funktionen mit einem zu installierenden Kontrollkästchen aus und drücke auf Weiter

Im nächsten Fenster werde ich dann mit folgendem Fehler aufgefordert:

Die Installation kann nicht abgeschlossen werden, da mindestens ein erforderliches Element nicht gefunden wurde. Zu installierende Software: C/C++ Remote Launch 6.0.0.201302132326 (org.Eclipse.cdt.launch.remote.feature.group 6.0.0.201302132326) Fehlende Anforderung: C/C++ Remote Debug Launcher 2.4.0.201302132326 (org.Eclipse.cdt.launch .remote 2.4.0.201302132326) erfordert 'bundle org.Eclipse.rse.ui [3.0.0,4.0.0)', konnte aber nicht gefunden werden .cdt.launch.remote.feature.group 6.0.0.201302132326) An: org.Eclipse.cdt.launch.remote [2.4.0.201302132326]

Das Seltsame ist, dass wenn ich im vorherigen Bildschirm nur die Installation der CDT MAIN-Funktionen auswähle, alles in Ordnung ist und ich gebeten werde, die Lizenzbedingungen zu akzeptieren, bevor die Installation tatsächlich stattfindet.

Ich habe also 2 Fragen:

  1. Irgendeine Idee, was das Problem lösen könnte?
  2. Halten Sie es für wichtig, die CDT OPTIONAL-Funktionen für die Standardprogrammierung und das Debuggen zu installieren?
4
Matteo

Nach einigem googeln stellte ich fest, dass das CDT für Eclipse von anderen spezifischen Eclipse-Komponenten abhängt, wie z. B. bundle org.Eclipse.rse.ui (der, den ich vermisse und der den Fehler verursacht). Eine Neuinstallation von Eclipse enthält möglicherweise noch nicht alle, sie können jedoch problemlos installiert werden.

Wählen Sie Hilfe> Neue Software installieren ... Klicken Sie auf den Link für Verfügbare Software-Sites. Stellen Sie sicher, dass es eine Aktualisierungssite mit dem Namen juno gibt. Ist dies nicht der Fall, klicken Sie auf Hinzufügen ... und geben Sie http://download.Eclipse.org/releases/juno als Speicherort ein.

Wenn Sie nun die Installationsschritte ausführen, sollte Eclipse die Abhängigkeiten des Plugins herunterladen und installieren, und alles funktioniert einwandfrei!

4
Matteo

um das Problem der Installation von Eclipse mit cdt c/c ++ Plugins zu lösen, gehen Sie am Terminal wie folgt vor:

apt-get install Eclipse eclipse-cdt Eclipse-jdt # don't include Eclipse if you have it already

führen Sie nach einer erfolgreichen Installation am Terminal die folgenden Schritte aus: pls Backup-Arbeitsbereich:

rm -rf ~/.Eclipse  
rm -rf ~/workspace  
Eclipse -clean &
5
meche