it-swarm.com.de

Boot-Splash durch "SP5100 TCO-Timer: MMIO-Adresse 0xyyyyyyy wird bereits verwendet"

Ich habe Ubuntu 11.04 mit den neuesten Updates. Ich habe eine ATI HD 4350-Grafikkarte und den "ATI/AMD-eigenen FGLRX-Grafiktreiber" aktiviert. Das gemeldete Verhalten wirkt sich nicht auf die Funktionalität aus, sondern ist nur eine optische Sache.

Beim Booten mit der Desktop-CD wurde der Ubuntu-Boot-Splash in hoher Auflösung korrekt angezeigt. Jetzt nach der Installation mit FGLRX ist das Dipsplay defekt (siehe Bild).

http://img824.imageshack.us/img824/7269/tcotimer.jpg

Dies ist, was in Dmesg zu finden ist

[    8.621803] SP5100 TCO timer: SP5100 TCO WatchDog Timer Driver v0.01
[    8.621967] SP5100 TCO timer: mmio address 0xfec000f0 already in use
[    8.622650] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[    8.622656] Disabling lock debugging due to kernel taint

Dies ist, was MMIO bedeutet: https://en.wikipedia.org/wiki/Memory-mapped_I/O

Irgendeine Idee, wie man den hochauflösenden Splash zurückbekommt?

5
mogliii

Sieht aus wie ein Bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/740011

Und es wurde sogar am 11. April behoben.

Launchpad Janitor wrote on 2011-04-11:
This bug was fixed in the package linux - 2.6.38-8.42

Überprüfen Sie Ihre Kernel-Version mit uname -a

Wenn es 2.6.38-8.42 ist, könnte es eine Regression sein, so dass Sie Ihr Dmesg-Protokoll zum obigen Fehler hinzufügen können.

Lösung für den Moment: Sie können SP5100_tco auf die Blacklist setzen und der Fehler wird behoben. Blacklisting SO WIRD'S GEMACHT: http://ubuntuforums.org/showthread.php?t=166624

2
Rinzwind