it-swarm.com.de

Wechseln zu Strg + Alt + F1 und zurück zum Desktop (Strg + Alt + F7): Leerer Bildschirm und verstümmelte Anzeige

Gehe zu tty1 mit Ctrl+Alt+F1.

Zurück zum Desktop mit Ctrl+Alt+F7

Bildschirme bleiben leer. Der Cursor ändert sich von einem Pfeil zu einer Hand.

Wenn ich dann den Deckel schließe und wieder öffne, kommt der Bildschirm wieder hoch, ist aber ernsthaft verstümmelt. Ich muss alle Anwendungen minimieren, um sie richtig zu machen. Der Desktop wird jedoch nicht aktualisiert und erfordert das Abmelden und Anmelden.

nvidia version 173 ist aktiv.

Was ist der beste Weg, dies zu versuchen?

13
Rinzwind

OK - meine Gedanken darüber, dies zu versuchen.

  • Ist das ein Compiz-Problem? Versuchen Sie, sich als Ubuntu Classic anzumelden

Schalten Sie alle visuellen Effekte aus. Kommt die verstümmelte Anzeige vor? Ist dies nicht der Fall, liegt wahrscheinlich ein Compiz-Problem vor. Ist dies der Fall, liegt möglicherweise ein Problem mit dem NVIDIA-Treiber vor.

Jetzt visuelle Effekte einschalten - Kommt die verstümmelte Anzeige vor? Wenn nicht, liegt wahrscheinlich ein Problem vom Typ Unity vor. Ist dies der Fall, handelt es sich wahrscheinlich eher um ein Compiz-Problem.

  • Ist das ein Treiberproblem? Deaktivieren Sie den nvidia-Treiber über das Fenster Additional Drivers. Kommt die verstümmelte Anzeige vor? Wenn dies nicht der Fall ist, liegt wahrscheinlich ein Problem zwischen nvidia driver und compiz vor.

CCSM wurde bewusst von der Standardinstallation ausgeschlossen, da festgestellt wurde, dass Benutzer, die Änderungen vornehmen, die grafische Anzeige instabil machen können. Wenn Sie mit verschiedenen CCSM-Einstellungen gespielt haben, ist dies möglicherweise Ihr Problem.

Versuchen Sie, compiz auf die Standardeinstellungen zurückzusetzen:

gconftool-2 --recursive-unset /apps/compiz
Sudo reboot --

Wiederholen Sie die obigen Schritte, um festzustellen, ob das Problem auf Änderungen in compiz zurückzuführen ist, die Sie möglicherweise vorgenommen haben.

6
fossfreedom

Es dauerte ein paar Neustarts, weil ich angefangen habe, die falschen Dinge zu untersuchen (Protokolldateien zeigen keine Fehler an), aber das Problem liegt in der nVidia-Treiberversion 173.

173 ist nicht der empfohlene Treiber, wie im Bild gezeigt, und das Zurücksetzen auf den empfohlenen hat das Problem ebenfalls gelöst.

enter image description here

(Das "nicht in Verwendung" scheint ein Fehler zu sein (Treiber wird verwendet), daher mache ich mir darüber keine allzu großen Sorgen.).

1
Rinzwind