it-swarm.com.de

Mein Sound und ALSA sind verschwunden, als ich Realtek-Treiber installiert habe

Ich habe mich mit einigen Informationen verwechselt und dachte, ich hätte eine Realtek-Audiokarte, aber in Wirklichkeit habe ich einen High Definition-Audiocontroller mit Intel 82801FB/FBM/FR/FW/FRW (ICH6-Familie), also als ich den Realtek High installiert habe Definition Audio-Codecs Es hat ein Durcheinander mit den Sound-bezogenen Dateien verursacht. In der Readme-Datei des Treibers heißt es, dass standardmäßig jeder Audiokanal stummgeschaltet wird und Sie einen ALSA- oder OSS-Mixer verwenden sollen, um die Stummschaltung aufzuheben Mir ist aufgefallen, dass ich diese Verwirrung gemacht habe, weil ich versucht habe, die Stummschaltung der Kanäle aufzuheben:

Sudo alsamixer gibt zurück: Mixer kann nicht geöffnet werden: Keine solche Datei oder kein solches Verzeichnis

Sudo amixer gibt zurück: amixer: Mixer attach default error: Keine solche Datei oder kein solches Verzeichnis

Ich habe bereits jedes alsa-realisierte Paket neu installiert und nichts erhalten. Das Ändern der Soundeinstellungen funktioniert nicht und es gibt keine Anweisungen zum Deinstallieren der Realtek-Treiber. Ich weiß, dass die Realtek-Treiber etwas im Zusammenhang mit "sdn" und "hda" geändert haben.

Wie kann ich dieses Problem beheben?

2
Rodrigo Martins

Dies ist aus ein Beitrag von Lidex in Ubuntu-Foren

Verwenden eines Terminals = "Anwendungen-> Zubehör-> Terminal"

Sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

Neustart

Für einen Fehler "Befehl nicht gefunden" installieren Sie einfach aptitude:

Sudo apt-get install aptitude

Die Realtek-Fahrer haben irgendwie für mich gearbeitet; es könnte einfach sein, dass der ALSA-Mixer ist nach der Treiberinstallation stummgeschaltet. Ich habe auch ein lustiges Problem festgestellt, dass die Soundkarte auf meinem Laptop irgendwie in Hardware stummgeschaltet sein kann = (Es gibt eine Tastenkombination zum Umschalten.)

Ich habe versucht, die Realtek-Treiber zu verwenden, aber schließlich die vorherige Version des Kernels neu installiert, von der ich wusste, dass sie mit chroot von der Live-CD funktioniert (eine alles andere als ideale Situation).

Das soll nicht heißen, dass die Realtek-Treiber nicht zum Laufen gebracht werden können, aber ich fand, dass sie mühsamer sind, als sie es wert sind.

Update: Ich habe weitere Probleme mit meinem Sound, die möglicherweise auf der Konkurrenz zwischen meiner Soundkarte und der Grafikkarte beruhen.

1
ej159

Mit diesem Link nehme ich mein Audio zweimal zurück, https://help.ubuntu.com/community/SoundTroubleshooterProcedure ... danach habe ich den Versuch aufgegeben, Realteak-Treiber zu installieren. = (

Sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; Sudo apt-get update;Sudo apt-get dist-upgrade; Sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` linux-alsa-driver-modules-$(uname -r) libasound2; Sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` linux-alsa-driver-modules-$(uname -r)  libasound2; killall pulseaudio; rm -r ~/.Pulse*; Sudo usermod -aG `cat /etc/group | grep -e '^Pulse:' -e '^audio:' -e '^Pulse-access:' -e '^Pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
0
Infernodot