it-swarm.com.de

Matplotlib kann unter Ubuntu 11.04 / ft2build.h nicht kompiliert werden: Keine solche Datei oder kein solches Verzeichnis

Ich versuche, matplotlib aus dem Quellcode zu erstellen, aber es funktioniert nicht. Es scheint, dass dieses Ding Teil von X11 war, und da Ubuntu jetzt Wayland verwendet, hat das alles vermasselt, denke ich.

Wie auch immer, um das zu beheben?

Oh ok. Ich musste nur libfreetype6 und libfreetype6-dev mit apt-get installieren. Ich kann es jetzt nicht beantworten, also bearbeite ich es später oder so.

4
ruh roh

Ich habe diese Abhängigkeiten in der Installationsdatei gefunden:

  matplotlib core: zlib, zlib-devel, libpng, libpng-devel,
                   freetype, freetype-devel, freetype-utils

  gtk backend: gtk2-devel, gtk+-devel, pygtk2, glib-devel,
               pygtk2-devel, gnome-libs-devel, pygtk2-libglade

  tk backend: tcl, tk, tkinter

Haben Sie alle diese installiert?

4
Lemurman

Ich sollte libfreetype-dev (Ubuntu) installieren.

3
Evgenii