it-swarm.com.de

Wie installiere ich die neueste Version von Groovy?

Ich habe Groovy bereits in meiner Ubuntu 10.10-Desktopversion installiert. Jetzt hat die Sprache ihre neueste Version von Groovy 1.8 veröffentlicht. Wenn ich versuche, mit demselben Befehl zu installieren, mit dem ich die vorherige Groovy-Version installiert habe, z. B .:

Sudo apt-get install groovy

Ich bekomme Fehler wie

0 upgraded, 0 newly installed, 0 to remove and 135 not upgraded.

Also, wie könnte ich installieren, ich bin ein Anfänger in Ubuntu, also hilf mir freundlich.

8
Ant's

Für eine bestimmte Ubuntu-Version werden die Standard-Repositorys selten mit neueren Softwareversionen aktualisiert. Die Software wird nur bei kritischen Supportproblemen und aus Sicherheitsgründen aktualisiert.

Ausnahmen gelten für wichtige Softwarekomponenten wie Firefox, die von Canonical unterstützt werden. In diesen Fällen wird entschieden, ob die Software im Vorfeld den Support verliert. Wenn dies der Fall ist, wird eine neuere Version im Repository aktualisiert.

"Groovy" ist meines Erachtens keine von Canonical unterstützte Software und wird daher nicht auf eine neuere Version aktualisiert.

Um neuere Softwareversionen zu erhalten, müssen Sie entweder den Quellcode selbst herunterladen und kompilieren und installieren - oder eine vertrauenswürdige PPA finden, bei der der Packager die Kompilierung für Sie durchgeführt hat.

V1.8 von Groovy wurde Ende letzten Monats veröffentlicht. Auch die nächste Version von Ubuntu (11.10) hat diese Version nicht in ihren Repositories.

4
fossfreedom

Entschuldigung für die späte Antwort, habe gerade diesen Beitrag gesehen. Sie finden ein alternatives Repository für Groovy, mit dem Sie die neuesten Groovy-Versionen unter Fresh Groovy installieren können. Für die neueste 1.8-Version finden Sie hier die Anweisungen auf der Website:

# first time users
Sudo apt-add-repository ppa:groovy-dev/groovy

# all users
Sudo apt-get update
Sudo apt-get install groovy-1.8
9
Mike Brady

Möglicherweise müssen Sie sdkman verwenden, um den neuesten Groovy wie gezeigt zum Laufen zu bringen hier auf der Seite "Groovy installieren"

Öffnen Sie einfach ein neues Terminal und geben Sie Folgendes ein:

$ curl -s get.sdkman.io | bash

Folgen Sie den Anweisungen auf dem Bildschirm, um die Installation abzuschließen.

Öffnen Sie ein neues Terminal oder geben Sie den Befehl ein:

$ source "$HOME/.sdkman/bin/sdkman-init.sh"

Dann installiere den neuesten stabilen Groovy:

$ sdk install groovy

Nachdem die Installation abgeschlossen ist und Sie sie zu Ihrer Standardversion gemacht haben, testen Sie sie mit:

$ groovy -version

Das ist alles dazu!

Ich hatte das gleiche Problem in Cloud9 IDE.

3
bitsnaps

SDKMAN ist der einfachste Weg, groovy zu installieren:

$ curl -s get.sdkman.io | bash
$ source "$HOME/.sdkman/bin/sdkman-init.sh"
$ sdk install groovy

das ist alles.

1
burtsevyg