it-swarm.com.de

Ubuntu wird nicht mehr angehalten, aber bei der Installation

Ich habe Ubuntu 10.10 neu installiert, als es herauskam, und mein Laptop war in Ordnung. Plötzlich kann ich meinen Laptop nicht mehr zum Anhalten bringen. Es ist ein HP Pavilion dv2-1110, aber ich glaube nicht, dass es sich um ein Hardwareproblem handelt. Hier ist der Grund dafür:

  • Es wurde bei der ersten Installation in Ordnung gebracht. Ich habe seitdem keine neuen Kernel mehr installiert, aber ich habe Unmengen von Paketen installiert, also ist es wahrscheinlich ein Paket.
  • Die Optionen "Anhalten" und "Ruhezustand" sind aus dem Menü "Herunterfahren" verschwunden. Wenn ich die Suspend-Taste meiner Tastatur drücke (oder den Deckel schließe), wird folgende Meldung angezeigt: alt text
  • Wenn ich den Befehl pmi action suspend versuche, erhalte ich die Fehlermeldung: Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files.
  • Wenn ich den Befehl echo -n mem > Sudo /sys/power/state versuche, erhalte ich absolut keine Ausgabe und keinen sichtbaren Effekt.

Was könnte dieses Verhalten verursachen? Ich dachte, eine Liste installierter Pakete könnte nützlich sein, aber sie ist riesig und ich weiß nicht, wie ich sie hier im Ein-/Ausklappmodus oder so etwas posten soll.

BEARBEITEN: Für den Fall, dass jemand danach fragt, ist keines der installierten Pakete kdm oder ähnliches (was den Mangel an Optionen im Shutdown-Menü von gnome rechtfertigen würde).

7
Malabarba

Öffnen Sie das Software-Center und geben Sie "acpi-support" in die Suchleiste ein. Stellen Sie sicher, dass das Paket installiert ist. Reboot und voilà: Suspend und Hibernate sind zurück und arbeiten wieder für mich. Vielleicht wird es auch für Sie behoben.

2
Gaurav Butola

Öffnen Sie Ihr Terminal und geben Sie dies ein

Sudo apt-get install hal
5
zolti

Ich weiß, dass es etwas spät ist, aber ich habe das gleiche Problem wie Sie.

Es stellt sich heraus, dass laptop-mode-tools bei der Installation pm-utils automatisch entfernt. Ich bin mir nicht sicher warum, aber es scheint, dass die 2 nicht gerne koexistieren.

Versuchen Sie erneut, pm-utils zu installieren: Sudo apt-get install pm-utils

Als Referenz fand ich dies heraus von: http://ubuntuforums.org/showthread.php?t=1660478

Ich hoffe, das hilft, Ihr Problem zu lösen.

1
Ollie Treend