it-swarm.com.de

Probleme mit kabelgebundenen und kabellosen Netzwerken mit PPPoE

Ich habe dieses Problem mit Ubuntu 10.10. Ich war mit Ubuntu 8.04 und habe mich dann entschlossen, Ubuntu 10.10 auszuprobieren.

Ich habe mit einer Live-CD gebootet und konnte das drahtlose Netzwerk mithilfe der Live-CD problemlos konfigurieren. Glücklicherweise habe ich Ubuntu 10.10 installiert. Sobald Ubuntu gestartet war, erkannte es das drahtlose Netzwerk und ich konnte eth1 eine statische IP zuweisen (ich verwende keine DHCP-Option auf meinem ADSL-Router) und einen WAP-Schlüssel eingeben und den Dialer mit pppoeconf konfigurieren . Das Netz war an und ich konnte im Netz surfen. Alles hunky dory bis jetzt. Beim nächsten Booten fing der Spaß jedoch an. Das drahtlose Netzwerk wurde nicht erkannt. Ich konnte das Netzwerkmanagersymbol im Systray nicht sehen. Ich habe ifconfig verwendet und festgestellt, dass der Eintrag für eth1 fehlt. Ich benutzte ifup eth1 und es wurde gesagt, dass eth1 bereits aktiv war.

Dann habe ich WLAN-Radar installiert. Wifi-Radar hat das drahtlose Netzwerk erkannt. Ich habe das WLAN-Radar für das erkannte WLAN-Netzwerk konfiguriert, den WAP-Treiber als WEXT festgelegt und die manuellen IP-Einstellungen verwendet. Wenn Sie jedoch auf Connect WiFi-Radar klicken, wird nach einer DHCP-IP gesucht, was natürlich fehlgeschlagen ist. Aus Liebe zu Gott kann ich nicht verstehen, warum WLAN-Radar DHCP verwendet, wenn ich manuelle Einstellungen vorgenommen habe.

Als nächstes entschied ich mich, das kabelgebundene Netzwerk zu verwenden, um im Internet nach einer Lösung zu suchen. Also habe ich das Netzwerkkabel von meinem Modem eingesteckt, es hat die eingesteckte Verbindung erkannt, ich habe eth0 konfiguriert, pppoeconf verwendet und eine Verbindung zum Netz hergestellt. Dann habe ich mich törichterweise entschlossen, meinen PC neu zu starten. Und Wunder der Wunder, erschien das gleiche Problem. Ich kann eth0 in meiner ifconfig nicht mehr sehen. Ich habe pon verwendet, um die DSL-Provider-Verbindung zu starten, und es wurde etwas über Netzwerkfehler oder so gesagt. Jetzt zeigt meine ifconfig nur noch lo, sowohl eth0 als auch eth1 sind verschwunden. Kann mir jemand dabei helfen?

Ist es ein Problem mit ipv6, wenn ja, wie kann man ipv6 unter Ubuntu 10.10 deaktivieren? OR ist dies ein bekanntes Problem mit Ubuntu 10.10?

P.S.

  1. Ich habe Linux Mint 10 ausprobiert und hatte das gleiche Problem. Beim Neustart wurde kein WLAN erkannt.
  2. Ich habe mich zum Administrator gemacht, damit keine Rechte oder irgendetwas in Frage kommen.
3
user9054

Damit Network Manager Ihre drahtlose Verbindung verwalten kann, darf Ihre drahtlose Schnittstelle NICHT in/etc/network/interfaces aufgeführt sein. Aber pppoeconf fügt es hinzu. Sie müssen es also entfernen.

Bearbeiten Sie/etc/network/interfaces, indem Sie ein Terminal öffnen und tippen

Sudo gedit /etc/network/interfaces

und löschen Sie die folgenden Zeilen:

auto wlan0
iface wlan0 inet manual

Starten Sie neu und Sie sollten bereit sein zu gehen.

1
kaapstorm

Das passiert mir jedes Mal, wenn ich pppoe nach einer Neuinstallation konfiguriere. Nach dem Neustart können die Netzwerkverbindungen nicht mehr verwaltet werden. Sie müssen Folgendes tun: Öffnen Sie das Terminal und geben Sie Folgendes ein:

Sudo -H gedit /etc/NetworkManager/NetworkManager.conf

du findest dort deine verbindung und änderst managed=false bis managed=true und starten Sie das System neu. Sie können Ihr Netzwerk wieder in Betrieb nehmen

1
Syed Khalil

Laut dem Fragesteller wurde das Problem mit wicd gelöst.

Sudo apt-get install wicd
0
djeikyb

Stellen Sie sicher, dass Sie die Ubuntu-Dokumentation zur drahtlosen Fehlerbehebung gelesen haben. Diese finden Sie unter https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/

Ich hatte kürzlich einen Verwandten mit einem ähnlichen Problem auf seinem Laptop. Es stellte sich heraus, dass die WLAN-Karte deaktiviert war und Fn + F12 musste gedrückt werden, um es einzuschalten (es kann sich auf Ihrem Computer unterscheiden, z. B. einen Schalter vor dem Laptop). Der Befehl rfkill list sollte zweimal "no" auf "Soft/Hard blockiert" für "Wireless LAN" anzeigen.

0
Lekensteyn