it-swarm.com.de

Php5 konnte nicht gefunden werden

als ich den Befehl Sudo apt-get install php5 gab, antwortete er mit der Fehlermeldung "php5 konnte nicht gefunden werden".

2
mini

Nun, es ist definitiv da drin (Beweis unten und hier ).

[email protected]:~$ apt-cache policy php5
php5:
  Installed: (none)
  Candidate: 5.3.3-1ubuntu9.3
  Version table:
     5.3.3-1ubuntu9.3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
     5.3.3-1ubuntu9 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
[email protected]:~$ 
[email protected]:~$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

Vorschläge:

  • Ist das ein neues System? Hast du Sudo apt-get update noch?

  • Ist dein /etc/apt/sources.list hoffnungslos korrumpiert? Zumindest sollte es einige der folgenden haben:

    deb http://archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse 
    deb http://archive.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse 
    deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse 
    deb http://archive.canonical.com/ubuntu maverick partner
    
1
Oli

möglicherweise liegt ein Problem mit Ihrer Repository-Konfiguration vor ...

poste hier die Ausgabe von

more /etc/apt/sources.list

php5 befindet sich im "main" -repository, daher sollten Sie dort eine Variante von haben

deb http://archive.ubuntu.com/ubuntu maverick main
0
Denwerko