it-swarm.com.de

Installation von gtk-config und / oder fsv, fehlende GTK-Abhängigkeiten

Ich versuche, den File System Visualizer (denke "Es ist ein UNIX-System! Ich weiß das!" Von Jurassic Park) auf Ubuntu 10.10 zu installieren.

Ich habe die .tar.gz heruntergeladen und extrahiert. Wenn ich jedoch ./configure, erhalte ich diese Ausgabe:

loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib
checking for POSIXized ISC... no
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for ANSI C header files... yes
checking whether time.h and sys/time.h may both be included... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for unistd.h... yes
checking for working const... yes
checking for mode_t... yes
checking for uid_t in sys/types.h... yes
checking for pid_t... yes
checking for size_t... yes
checking for comparison_fn_t... yes
checking for st_blocks in struct stat... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for working alloca.h... yes
checking for alloca... yes
checking for working fnmatch... yes
checking for strftime... yes
checking for getcwd... yes
checking for gettimeofday... yes
checking for mktime... yes
checking for strcspn... yes
checking for strdup... yes
checking for strspn... yes
checking for strtod... yes
checking for strtoul... yes
checking for scandir... yes
checking for inline... inline
checking for off_t... yes
checking for unistd.h... (cached) yes
checking for getpagesize... yes
checking for working mmap... yes
checking for argz.h... yes
checking for limits.h... yes
checking for locale.h... yes
checking for nl_types.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for unistd.h... (cached) yes
checking for sys/param.h... yes
checking for getcwd... (cached) yes
checking for munmap... yes
checking for putenv... yes
checking for setenv... yes
checking for setlocale... yes
checking for strchr... yes
checking for strcasecmp... yes
checking for strdup... (cached) yes
checking for __argz_count... yes
checking for __argz_stringify... yes
checking for __argz_next... yes
checking for stpcpy... yes
checking for LC_MESSAGES... yes
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for libintl.h... yes
checking for gettext in libc... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for gtk-config... no
checking for GTK - version >= 1.2.1... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: Cannot find proper GTK+ version

Offensichtlich sucht es nach gtk-config. Jedoch anscheinend existiert es nicht mehr in den Repos. Dann dieser Beitrag erwähnte, dass gtkglarea ihr Problem gelöst hat, wie in diese Datei erwähnt.

Natürlich vergisst dieses Poster ordentlich, genau zu erwähnen, was und wie gtkglarea ihr Problem gelöst hat, und Google ist größtenteils leer von Informationen über das Problem.

Also komme ich hierher und bitte um Hilfe! Ich möchte fsv installieren, aber es sagt mir, dass gtk-config nicht existiert. Wie kann ich dieses Problem in Ubuntu 10.10 beheben?

Vielen Dank!

EDIT

Mit Hilfe von Robert musste ich Folgendes tun:

Aus den Dapper-Repositorys, die ich heruntergeladen habe:

libgtk1.2-dev_1.2.10-18_i386.deb
libgtk1.2_1.2.10-18_i386.deb
libgtk1.2-common_1.2.10-18_all.deb
gtkglarea5-dev_1.2.3-2ubuntu4_i386.deb
gtkglarea5_1.2.3-2ubuntu4_i386.deb
libglib1.2_1.2.10-10.1build1_i386.deb
libglib1.2-dev_1.2.10-10.1build1_i386.deb

dann musste ich installieren:

  1. libglib1.2
  2. libglib1.2-dev
  3. libgtk1.2-common
  4. libgtk1.2
  5. libgtk1.2-dev
  6. gtkglarea5
  7. gtkglarea5-dev

Ich habe Sudo gdebi <file>.deb für die meisten von ihnen verwendet (es zeigt Ihnen Abhängigkeiten besser an, wenn Sie eine verpasst haben). In einigen Fällen tut gdebi nicht das Richtige und stirbt. Verwenden Sie in diesem Fall dpkg -i <file>.deb und es sollte funktionieren.

6
Wayne Werner

Wenn die Bibliothek noch von jemandem benutzt oder gewünscht wird, wie kann sie veraltet sein?

Ich hatte das gleiche Problem beim Erstellen von Mozilla 1.7.13 (ja, der alte Mozilla-Browser).

Ich habe dieses Problem in 10.10 behoben, indem ich das dapper-Paket und alle Abhängigkeiten manuell installiere:

https://launchpad.net/ubuntu/dapper/i386/libgtk1.2-dev/1.2.10-18

du brauchst:

libglib1.2_1.2.10-10.1build1_i386.deb
libglib1.2-dev_1.2.10-10.1build1_i386.deb
libgtk1.2-common_1.2.10-18_all.deb
libgtk1.2_1.2.10-18_i386.deb
libgtk1.2-dev_1.2.10-18_i386.deb
5
Robert

Es gibt eine aktualisierte Version von fsv auf GitHub: https://github.com/mcuelenaere/fsv . Es wurde geändert, um mit GTK 2.0 zu arbeiten, und funktioniert für mich unter Linux Mint 13 (mit Ubuntu 12.04-Paketen).

4
Arjen

diese Software ist nicht gepflegt und erfordert GTK1, eine veraltete grafische Bibliotheksversion. Sie ist nicht in den Ubuntu-Repositories verfügbar, und mir ist kein Repository bekannt, das sie bereitstellt.

Ich würde Ihnen empfehlen, sich an den Software-Autor zu wenden und mit ihm zu klären, ob ein Upgrade geplant ist, oder auf andere Weise nach einer ähnlichen Software zu suchen, die gewartet wird.

2
João Pinto