it-swarm.com.de

Glib-dev kann nicht installiert werden

Ich habe versucht, dasher zu bauen, aber ich habe es benötigt glib. Dabei ist folgendes aufgetaucht:

Checking for GLIB... configure: error: Package requirements (glib-2.0>= 2.6) were not met:
No package 'glib-2.0' found

Also habe ich versucht libglib2.0-dev zu installieren

Es gab einen anderen Fehler:

libglib2.0-dev:
  Depends: libglib2.0-0 (=2.26.0-0ubuntu1) but 2.26.1-0ubuntu1 is to be installed
  Depends: libglib2.0-bin but it is not going to be installed

Was soll ich tun?

4
las

Das Problem ist, dass Sie das Paket mit dpkg installieren, wodurch keine Abhängigkeiten installiert werden. Du musst apt-get verwenden (das könnte auch so sein):

Sudo apt-get install libglib2.0-dev

Auf diese Weise werden alle benötigten Abhängigkeiten automatisch installiert.

3
David Alfonso

2.26 bezieht sich auf GNOME 2.26, eine alte Version. Haben Sie Ubuntu 9.10 oder eine ähnliche alte Ubuntu-Distribution?

Wenn Sie Ihre Distribution aktualisieren können, sollten Sie in der Lage sein, diese Probleme zu lösen. Wenn Sie kein Upgrade durchführen können, besorgen Sie sich ein älteres Paket des Quellcodes des Programms, das mit dasher kompiliert wird.

0
user4124

2.26 bezieht sich tatsächlich auf die glib-Version, nicht auf die GNOME-Version und ist für Einzelgänger aktuell. Ich glaube, Sie haben gerade eine Zeit erreicht, in der bestimmte Pakete deinstalliert werden können, wenn ein Arch vor dem anderen erstellt wird. Kann dies immer noch nicht installiert werden?

0
micahg